[Digikam-users] Digikam 2.0 runs only once before corrupting the DB

sleepless sleeplessregulus at hetnet.nl
Mon Aug 22 22:19:27 BST 2011

Hi Marie-Noëlle,

To build from git, this should be the procedure, but this time I ran 
into trouble not solved yet.
If I manage to figure out what went wrong I will update.


If git is not already installed, install git:

open console


sudo apt-get install git

if done:


git clone http://anongit.kde.org/digikam-software-compilation

If all went succesfull, you can now find the directorie:


go in console to ¨your_user_dir¨


cd digikam-software-compilation

if you type:


you will see in this dir a document called ¨download-repos¨ , this is a 
runnable PERL script.


sudo perl download-repos

Now the git is cloned to your local dir: 

wait while downloading

If cmake is not installed, now type:

sudo apt-get install cmake

if done type:

sudo cmake -DCMAKE_BUILD_TYPE=debugfull 
-DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..

No it may complain about missing stuff. Try to install it from synaptic 
or in any other way and retry

cmake untill succesfull

now run:


if done run:

sudo make install


More information about the Digikam-users mailing list