[Digikam-users] libopenni and openni-utils doesn't configure

Hervé Le Roy hleroy at hleroy.com
Thu Aug 11 11:48:41 BST 2011

2011/8/11 manfred <manfred.1980 at freenet.de>:
> Thanks Herve,
> at least one, who experienced the same problem.
> may I ask: on your working platform does
> libopenni have openni-utils as dependency?


> aptitude show libopenni
Package: libopenni
Depends: libc6 (>= 2.11), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx |
libgl1, libstdc++6 (>= 4.1.1), libusb-1.0-0 (>= 2:1.0.8), openni-utils

> Like Philip mentioned earlier I think I should first install libopenni and the
> libopenni shouldn't have dependencies. Well, actually Mark's output shows the
> same, but he didn't mention problems.
> I want to mention again, that openni on its website says, openni needs
> processors handling SSE3. My thinkpad t43p pentium mobile 4 doesn't have it.
> They say one could change the flags for the makefiles, to make it work on
> processors with no SSE3 support.
> I tried my best, but that higher than my level of knowledge. Installing from
> the sources was not possible for me with the original downloaded sources from
> openni website.

I can't check right now if SSE3 is available on my friend's computer.
Its computer is probably 4-5 years old, so maybe yes maybe not (I see
on Wikipedia that SEE3 was first introduced in 2004). I'll check when
he's back next week.


More information about the Digikam-users mailing list