[Digikam-users] Re: Update problems

David Vincent-Jones davidvincentjones at gmail.com
Fri Apr 15 23:37:19 BST 2011

Interim feedback:

Did not yet try the latest idea but after making today's update I still
had the identical problem message.

DK does start from the terminal with "digikam" command but also signals
the following error:
"david at david-desktop:~$ digikam
KGlobal::locale::Warning your global KLocale is being recreated with a
valid main component instead of a fake component, this usually means you
tried to call i18n related functions before your main component was
created. You should not do that since it most likely will not work 
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is
still in use, all queries will cease to work."

I will now try Philip's workaround and see what occurs.


On Sat, 2011-04-16 at 00:30 +0200, Philip Johnsson wrote:
> Look if you have saved a custom menu entry for Digikam. Check in
> ~/.local/share/applications/ if you have a file called
> kde4-digikam.desktop or maybe digikam.desktop. In that case it's a
> user saved menu entry that overrides the updated system wide menu. If
> you have it and remove it you might need to log out and in again to
> repopulate the menu with the system wide version of the menu file.
> If you do this with the KDE Menu Editor you should have
> "LD_PRELOAD=/lib/libusb-0.1.so.4 digikam -caption "%c" %i" in the
> field "Command:" for the Digikam menu entry. The
> "LD_PRELOAD=/lib/libusb-0.1.so.4" is a workaround against crashes in
> beta4 when you try to import images from a camera that uses
> libgphoto2, usually PTP cameras. The old workaround was
> "LD_PRELOAD=/usr/lib/libusb.so" but shouldn't be used by non
> developers.
> Hope this make any sense.
> /Philip
> On Sat, Apr 16, 2011 at 12:04 AM, bowens44 <bowens44 at gmail.com> wrote:
>         I did an apt-get --purge remove digikam2* kipi*
>         I then reinstalled digikam2
>         I still get "Could not launch digiKam
>         Failed to execute child process
>         "LD_PRELOAD=/usr/lib/libusb.so" (No such
>         file or directory)" when launching from the menu.
>         ~$ sudo dpkg -l | grep digikam*
>         ii  digikam2
>         2:2.0.0~beta4+maverick~ppa3kde46                  digital
>         photo management
>         application for KDE
>         ii  digikam2-data
>         2:2.0.0~beta4+maverick~ppa3kde46                  digikam
>         architecture-independant data
>         i'm not sure what is happening but if it's just me then
>         obviously something
>         is wrong on my side.
>         --
>         View this message in context:
>         http://digikam.1695700.n4.nabble.com/Update-problems-tp3450947p3453094.html
>         Sent from the digikam-users mailing list archive at
>         Nabble.com.
>         _______________________________________________
>         Digikam-users mailing list
>         Digikam-users at kde.org
>         https://mail.kde.org/mailman/listinfo/digikam-users
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users

More information about the Digikam-users mailing list