[Digikam-users] libkdcraw problem

Gandalf Lechner gandalf.lechner at univie.ac.at
Tue Mar 30 10:29:44 CEST 2010

Hi all,

following the instructions on
http://www.digikam.org/drupal/download?q=download/KDE4 as usual, I
compiled and installed the kdegraphics libs (using kubuntu 10.04 beta1).
Before that, I removed all libkdcraw packages installed via the package
manager. But still, compiling digikam fails. (It used to work a couple
of days ago.) In the config output, it says

--  libkdcraw library found.................. YES

but also 

--  libkdcraw >= 1.0.0 library found......... NO  (optional)

which is strange because I just installed the very newest version
available. Compilation of digikam then fails with the message

[ .. ]
[  1%] Building CXX object
In file included
from /home/gandalf/down/svn/kde4/graphics/digikam/libs/dimg/dimg.h:42,

from /home/gandalf/down/svn/kde4/graphics/digikam/libs/dimg/dimg.cpp:26:
In constructor ‘Digikam::DRawDecoding::DRawDecoding(const
/home/gandalf/down/svn/kde4/graphics/digikam/libs/dimg/drawdecoding.h:70: error: ‘DontStretchPixels’ was not declared in this scope
/home/gandalf/down/svn/kde4/graphics/digikam/libs/dimg/drawdecoding.h:70: error: ‘const class KDcrawIface::RawDecodingSettings’ has no member named ‘DontStretchPixels’
make[2]: ***
[digikam/digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/dimg.o] Fehler
make[1]: *** [digikam/digikam/CMakeFiles/digikamcore.dir/all] Fehler 2
make: *** [all] Fehler 2

Any idea what's wrong here?


More information about the Digikam-users mailing list