[Digikam-users] Odd behaviour of geotagging in digiKam 1.3.0

Michael G. Hansen mike at mghansen.de
Tue Jul 20 20:17:21 CEST 2010


On 07/20/2010 05:28 PM, Stedtlund wrote:
> Hi,
>
> I have just gone up to digiKam 1.3.0, and I can see a rather odd
> behaviour when geotagging images.
>
> The first image worked ok, but after that one I couldn't choose any
> coordinates because the map was just gray. Choosing a bookmarked
> position only gave the coordinates 0, 0, 0.
>
> Then I saw under properties that there were two radiobuttons for
> choosing api towards google. In my swedish translated version those
> two had the same api versions, V2. The first was selected so  tried
> the second, and now it works allmost as before. The only difference
> seems to be that it's only possible to zoom in/out with +/- buttons.
> The scale is not visible any more.

The first option should be V2, the second one should be V3. Maybe you 
can file a bug report about this for the translation team? Each of the 
APIs has its own quirks, so we make both of them available, and the user 
can use the one that works better for him.

With the V2 version, a known problem is that after a few times of 
opening the coordinates editor, no satellite tiles are displayed for 
some hours or until you change your IP address.

Zooming with the scroll wheel works fine for me in V3 here.

Another test would be to load the Google Maps code which we use in 
Konqueror, to see whether it is a configuration issue (adblock, images 
disabled, javascript disabled, ...):

http://digikam3rdparty.free.fr/gpslocator/getlonlatalt.php?gmapsversion=3

http://digikam3rdparty.free.fr/gpslocator/getlonlatalt.php?gmapsversion=2

I hope this helps you somewhat,

Michael


More information about the Digikam-users mailing list