[Digikam-users] Error when I compile Kdegraphics libs from svn

Nicolas Morange nicolas.morange at polytechnique.org
Mon Mar 16 11:43:37 CET 2009


Hi,
A cleaner way might be te create a package, with checkinstall for instance. If 
you  indicate /usr as install prefix during make, and if you use checkinstall 
instead of make install, then put proper metadata (such as replace 
libexiv2<=0.17), that could work.

Nicolas

On Monday 16 March 2009 11:24:29 Photonoxx wrote:
> Exiv2 was installed in /usr/local/
> and I have libexiv2 (0.17-1) installed in /usr/lib/
>
> So i rename libexiv2.so.4.0.0 and copy with the same name
> libexiv2.so.5.2.0 from /usr/local/lib/
>
> The make stage seems to work, but I things it's not a very proper way to
> do that's work fine.
>
> Thanks if you have any suggest to make thing more properly
>
> Nicolas
>
>
> Le Mon, 16 Mar 2009 11:03:39 +0100, Photonoxx <smtp.no at laposte.net> a
>
> écrit:
> > Excuse, may be i was to fast to answer.
> >
> > In synaptic I have already Libexiv2 (0.17 1) installed. But if i want to
> > remove, it asks me to remove a lot of another package that I want keep,
> > if
> > it's possible.
> >
> > Could this old libexiv2 the source of the matter ?
> >
> > Thanks
> >
> > Nicolas
> >
> > Le Mon, 16 Mar 2009 10:50:34 +0100, Gilles Caulier
> >
> > <caulier.gilles at gmail.com> a écrit:
> >> Sound like you have more than one Exiv2 devel package instaed (with
> >> header
> >> files)
> >>
> >> Try to clean up your install.
> >>
> >> Gilles Caulier
> >>
> >> 2009/3/16 Photonoxx <smtp.no at laposte.net>
> >>
> >>> Hi,
> >>>
> >>> I recently reinstalled my Ubuntu system ( Ubuntu 8.10 64bits) and I try
> >>> know to compliling the last version of digikam.
> >>>
> >>> I have installed KDE 4.2 by activating Backports repository
> >>>
> >>> I have installed too dependencies mentionned in the followings pages :
> >>>
> >>>
> >>> http://techbase.kde.org/Getting_Started/Build/KDE4/Kubuntu_and_Debian
> >>>
> >>>
> >>> http://wiki.kde.org/tiki-index.php?page=Digikam+Compilation+on+Kubuntu+
> >>>Intrepid
> >>>
> >>> And I follow the procedure describe in the last page listed above.
> >>>
> >>> but when I try to make the Kdegraphics part, the process stop at the
> >>> libkexiv stage with this messages :
> >>>
> >>> Linking CXX shared library ../../../lib/libkexiv2.so
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `KExiv2Iface::KExiv2::setExifThumbnail(QImage const&, bool) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:835: undefined reference to
> >>> `Exiv2::ExifThumb::ExifThumb(Exiv2::ExifData&)'
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:836: undefined reference to
> >>> `Exiv2::ExifThumb::setJpegThumbnail(unsigned char
> >>> const*, long)'
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `KExiv2Iface::KExiv2::getExifThumbnail(bool) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:741: undefined reference to
> >>> `Exiv2::ExifThumbC::ExifThumbC(Exiv2::ExifData const&)'
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:742: undefined reference to `Exiv2::ExifThumbC::copy()
> >>> const'
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `KExiv2Iface::KExiv2::getExifTagString(char const*, bool) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:691: undefined reference to
> >>> `Exiv2::Metadatum::print(Exiv2::ExifData const*) const'
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `KExiv2Iface::KExiv2::setExifTagData(char const*, QByteArray const&,
> >>> bool)
> >>> const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:396: undefined reference to
> >>> `Exiv2::DataValue::DataValue(unsigned char const*,
> >>> long, Exiv2::ByteOrder, Exiv2::TypeId)'
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `KExiv2Iface::KExiv2::setExif(QByteArray const&) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2exif.cpp:121: undefined reference to
> >>> `Exiv2::ExifParser::decode(Exiv2::ExifData&, unsigned char const*,
> >>> unsigned int)'
> >>> CMakeFiles/kexiv2.dir/kexiv2exif.o: In function
> >>> `Exiv2::ExifParser::encode(std::vector<unsigned char,
> >>> std::allocator<unsigned char> >&, Exiv2::ByteOrder, Exiv2::ExifData
> >>> const&)':
> >>> /usr/local/include/exiv2/exif.hpp:570: undefined reference to
> >>> `Exiv2::ExifParser::encode(std::vector<unsigned char,
> >>> std::allocator<unsigned char> >&, unsigned char const*, unsigned int,
> >>> Exiv2::ByteOrder, Exiv2::ExifData const&)'
> >>> CMakeFiles/kexiv2.dir/kexiv2iptc.o: In function
> >>> `KExiv2Iface::KExiv2::setIptcTagData(char const*, QByteArray const&,
> >>> bool)
> >>> const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2iptc.cpp:285: undefined reference to
> >>> `Exiv2::DataValue::DataValue(unsigned char const*,
> >>> long, Exiv2::ByteOrder, Exiv2::TypeId)'
> >>> CMakeFiles/kexiv2.dir/kexiv2iptc.o: In function
> >>> `KExiv2Iface::KExiv2::setIptc(QByteArray const&) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2iptc.cpp:123: undefined reference to
> >>> `Exiv2::IptcParser::decode(Exiv2::IptcData&, unsigned char const*,
> >>> unsigned int)'
> >>> CMakeFiles/kexiv2.dir/kexiv2iptc.o: In function
> >>> `KExiv2Iface::KExiv2::getIptc(bool) const':
> >>>
> >>> /home/naruchan/Download/sources/svn/kdegraphics/libs/libkexiv2/libkexiv
> >>>2/kexiv2iptc.cpp:94: undefined reference to
> >>> `Exiv2::IptcParser::encode(Exiv2::IptcData const&)'
> >>> collect2: ld a retourné 1 code d'état d'exécution
> >>> make[2]: *** [lib/libkexiv2.so.7.2.0] Erreur 1
> >>> make[1]: *** [libs/libkexiv2/libkexiv2/CMakeFiles/kexiv2.dir/all]
> >>> Erreur 2
> >>> make: *** [all] Erreur 2
> >>>
> >>> I want to precise that I have installe exiv2 0.18 from tarball
> >>>
> >>> Does somebody have any idea of where may I make something wrong ?
> >>>
> >>> Thanks
> >>>
> >>> Nicolas
> >>>
> >>>
> >>> --
> >>> Nicolas Boulesteix - Chasseur de lueurs - http://www.photonoxx.fr
> >>>
> >>> _______________________________________________
> >>> Digikam-users mailing list
> >>> Digikam-users at kde.org
> >>> https://mail.kde.org/mailman/listinfo/digikam-users




More information about the Digikam-users mailing list