[Digikam-users] Failed to copy old database file

Marcel Wiesweg marcel.wiesweg at gmx.de
Thu Mar 19 22:44:13 GMT 2009

Am Donnerstag 19 März 2009 schrieb Mark Alford:
> On Thu, 19 Mar 2009, Marcel Wiesweg wrote:
> > That's your problem, noone ran into this before ;-) At least not that I
> > know of.
> Thou art rude but I forgive thee because thou hast healed my digikam (see
> below)

I was referring to the "that we did not expect" part of the error message

> > Please check the digikamrc file digikam is accessing. There should be an
> > Album Path entry. And it should be the same file you used with digikam
> > 0.9 before - or did you enter the location in the dialog appearing on
> > first run?
> This was the key to the problem. When I upgraded from Fedora 9
> to 10, the ~/.kde directory didn't get copied across to my new home dir
> so there was no digikamrc file in ~/.kde/share/config/
> Luckily I still have a backup copy of my old Fedora 9 home directory, so I
> just copied the digikamrc file across from there, and then when I started
> digikam it worked fine, copying the old database to the new format.

All right. Actually, this requirement to have a digikamrc worked for 99% of 
users, but it's not strictly necessary. Will think about it for 0.11.

> Many thanks for your help.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20090319/2013f89b/attachment.html>

More information about the Digikam-users mailing list