[Digikam-users] Compiling kipi-plugins #930483 troubles with KdepimLibs

Jurian Sluiman subscribe at juriansluiman.nl
Mon Feb 23 17:03:48 GMT 2009

On Monday 23 February 2009 17:50:07 Gilles Caulier wrote:
> 2009/2/23 Jurian Sluiman <subscribe at juriansluiman.nl>:
> > Hi all,
> > I've been compiling Digikam for a while now. Digikam is almost the only
> > thing I'm compiling at my Kubuntu Intrepid system (except the
> > requirements, everything else is installed from repositories). Following
> > the wiki
> > (http://wiki.kde.org/tiki-index.php?page=Digikam+Compilation+on+Kubuntu+I
> >ntrepid) always worked very well.
> >
> > Now I was trying to compile kipi-plugins and got this error (only
> > relevant
> >
> > parts quoted):
> >
> > I don't understand this error, because what has kipi-plugins to do with
> > kdepim? Searching to "kipi-plugins KdepimLibs_DIR" gives no results in
> > Google.
> >
> > Please give me some advice how to tackle this problem :)
> kipi-plugins do not use kdepimlibs, but digiKam.
> In digiKam, it's optional. Look in README file, there is an option to
> pass to CMake.
> Else, install KDEPimlibs development package, and all will be fine...
> Best
> Gilles Caulier
> _______________________________________________
Hi Gilles,
Thanks for the really fast answer. I looked at apt and asked to install 
kdepimlibs5-dev, but that was already installed. Ok, something wrong, but I 
don't need the KAddresbook thing.

Therefore, I tried to tell cmake to disable kdepimlibs. README says I can 
disable gphoto2 by -DENABLE_GPHOTO2=no. I used this example to disable 
kdepimlibs: -DENABLE_KDEPIMLIBS=no. The whole Cmake rule is now:
DENABLE_KDEPIMLIBS=no ../../graphics/

Still, Cmake is trying to find KdepimLibs ("Could NOT find KdepimLibs  
(missing:  KdepimLibs_CONFIG)". Doing something wrong?


More information about the Digikam-users mailing list