[Digikam-users] Digikam is really slow when used with NFS and wireless

Colin Guthrie gmane at colin.guthr.ie
Thu Jun 5 10:07:41 CEST 2008


Andreas Weigl wrote:
> Hi
> 
> Am Wednesday 04 June 2008 schrieb Stefanovich:
>> I did a search and couldn't find any solutions to this. I have digikam
>> setup to use an NFS folder as it's library. It works great when I am
>> connected via a cat 5 cable, however whenever I switch to wireless on
>> my laptop digikam's gets really really slow. Everything from startup
>> to photo access. Is this simply a case of me having a slow wireless
>> connection, or is there another issue when dealing with Digikam, nfs,
>> and wireless all together? My transfer rates between my local network
>> appear really fast when on wireless which makes me think that isn't
>> the problem.
>>
>> Any help would be appreciated!
> 
> * What is the speed of your wireless network? Check with iwconfig.
> * How much traffic do you see? A good tool is iptraf. Maybe do a wget of a 
> large file and check the speed
> * Are you the only person using the access point?
> * What are the mount parameters that you are using? I suggest nolock and noac.

Could this be related to the locking of the SQLite DB which (as has been 
documented many, many times) is generally a bad thing.

The same problems will be apparent not that FF3 uses SQLite.

I'm not sure where it's at at the moment, but SQLite over NFS really 
needs to get a whole lot better (assuming this hasn't already happened 
and I missed it ;))

Col



More information about the Digikam-users mailing list