[Digikam-users] Pictures still not showing, reopen 165885?

Gilles Caulier caulier.gilles at gmail.com
Sun Jul 27 16:13:55 BST 2008

2008/7/27 Dotan Cohen <dotancohen at gmail.com>:
> 2008/7/27 Gilles Caulier <caulier.gilles at gmail.com>:
>> 2008/7/27 Dotan Cohen <dotancohen at gmail.com>:
>>> 2008/7/27 Andi Clemens <andi.clemens at gmx.net>:
>>>> Another note: If I setup my system so that it can't find the kioslaves, I get
>>>> the same result as you have: The splitter is gone (due of an "empty" album I
>>>> guess) ...
>>>> Oh right now I have read your comment again in the bugreport: You really can't
>>>> find the kioslave. Try to make sure that your settings are correct, this is
>>>> not a bug in general!
>> And this is the base of all problem to run digiKam on your computer.
>> Solve kioslave in first before to continue to test and report
>> Best
> I will try to do that, Gilles. I really don't know where to start,
> though, but I'll hit google. Which KDE mailing list is appropriate to
> ask on?
> Thanks for the help, and I apologize if I'm taking up more developer's
> resources than I'm helping with.
I'm pretty sure than it's a problem of env. variables not set.

Here, under Mandriva 2008.1, KDE4 is installed to /opt/kde4

if i run digikam like this : /opt/kde4/bin/digikam, i have the same
problem than you...

I need to use the "k4" script to run an application outside KDE4
desktop (this is the case here. i don't run KDE4 but KDE3 desktop,
because this one is stable and need something _stable_ to work)....

So, from shell, i do "k4 digikam"... and all work fine. kioslave run

Now, we will see what the k4 script set. Form a fresh konsole instance
under KDE3, i do the following lines :

[gilles at localhost ~]$ export > before.txt
[gilles at localhost ~]$ k4
[gilles at localhost ~]$ export > after.txt
[gilles at localhost ~]$ diff before.txt after.txt
> declare -x DBUSDIR="/opt/kde4"
> declare -x KDEDIR="/opt/kde4"
> declare -x KDEDIRS="/opt/kde4"
> declare -x KDEHOME="/home/gilles/.kde4"
> declare -x KDETMP="/home/gilles/tmp/gilles-kde4"
> declare -x KDEVARTMP="/var/tmp/gilles-kde4"
> declare -x LD_LIBRARY_PATH="/opt/kde4/lib:"
< declare -x PATH="/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt4/bin:/home/gilles/bin:/usr/lib/qt4/bin"
> declare -x PATH="/usr/lib/qt4/bin:/opt/kde4/bin:/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt4/bin:/home/gilles/bin:/usr/lib/qt4/bin"
< declare -x QTDIR="/usr/lib/qt3"
> declare -x QTDIR="/usr/lib/qt4"
> declare -x QT_PLUGIN_PATH="/opt/kde4/lib/kde4/plugins"
[gilles at localhost ~]$

"Et Voilà" I hope that it will help you.

Gilles Caulier

> --
> Dotan Cohen
> http://what-is-what.com
> http://gibberish.co.il
> א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-נ-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת
> A: Because it messes up the order in which people normally read text.
> Q: Why is top-posting such a bad thing?
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users

More information about the Digikam-users mailing list