[Digikam-users] Rename files on disk?

enaut enaut.w at googlemail.com
Thu Jul 3 07:55:12 BST 2008

Jason Antman schrieb:
> Hi,
> This is my first time using digikam. I read about & installed it a few 
> weeks ago, in preparation for getting a new digital camera (Nikon D80, a 
> bit worried about Linux compatibility).
experiences here because I plan to buy me one too.
>  I'm running digikam 0.9.3 on 
> OpenSuSE 10.3/KDE4.
> I just took about 100 photos of things I'm going to be selling online. 
> Not wanting to deal with the "dscnXXX" names, I added the directory in 
> digikam as a new album, and proceeded to rename and rotate them as 
> needed. Now... the names aren't there on disk, and the rotations aren't 
> there either. I've looked through the docs and saw an option to export 
> to CD/DVD, but no option to write all changes from the album to disk. 
> I'm going to be using the images in web pages, and don't want any 
> galleries to be automatically generated - I already have a script that 
> handles that.
I just tried it with my installation of Digikam 0.9.3 on ubuntu and a
local harddrive and the renaming worked perfectly well. Just rightclick
on an Image and press rename thats it. If that is not working  there
could be an issue with the filesystem or something similar.
Same with the rotate funktion. The only issue here is, that gnome has
got the old unrotated thumbnail in its cache but the image is rotated.
> Thanks for any advice,
> Jason
> PS - I'm very wary about any program that keeps images in some hidden 
> location, or just generates meta information in a database. Not only do 
> I often need to do quick exports of a directory of images to disk, but I 
> also need the images to be in finished state on disk (my albums are on 
> remote shares, NFS or SSHFS/Fuse, and are also accessed through a web 
> interface).
You can set in the options pretty much everything to store in the
file... (author comments tags etc). My guess is, that your configuration
does not permit file modifications as Digicam wants to do them.
Therefore its not working. you may try to start Digikam in the console
to get an output if something went wrong.


More information about the Digikam-users mailing list