[Digikam-users] Digikam ver.9 wont compile on Freebsd

Leslie Jensen leslie at eskk.nu
Thu Aug 30 07:53:11 BST 2007


I have a problem with with compiling graphics/digikam.

All dependencies are installed!

Have tried almost all I know...!

I have managed to install ver. 8 as a package but it wouldn't start.

I got the following error which I solved by creating a symlink.

/libexec/ld-elf.so.1: Shared object "libImlib2.so.3" not found, required
by "digikam"

I've tried to reinstall imlib and imlib2 the result is the same.

Can't find anything on Google

I need a little help to find where the error lays.


Below are the result of

portupgrade -fr graphics/digikam

if /bin/sh /usr/local/bin/libtool --silent --tag=CXX --mode=compile c++
ONFIG_H -I. -I. -I../../.. -I../../../digikam/digikam
es/imageeditor/editor -I../../../digikam/libs/jpegutils
themeengine -I../../../digikam/libs/imageproperties -I/usr/local/include
../../digikam/libs/widgets/common -I../../../digikam/libs/dimg
m/libs/dmetadata -I/usr/local/include/gphoto2 -I/usr/local/include
l/include  -I/usr/local/include  -D_THREAD_SAFE -pthread
I/usr/local/include -I/usr/local/include  -I/usr/local/include
READ_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith -O2
sing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new
-fno-common -DQT
".deps/gpcamera.Tpo" -c -o
gpcamera.lo gpcamera.cpp; \
         then mv -f ".deps/gpcamera.Tpo" ".deps/gpcamera.Plo"; else rm
-f ".deps/
gpcamera.Tpo"; exit 1; fi
In file included from /usr/include/c++/3.4/bits/postypes.h:46,
                  from /usr/include/c++/3.4/iosfwd:50,
                  from /usr/include/c++/3.4/ios:44,
                  from /usr/include/c++/3.4/ostream:45,
                  from /usr/include/c++/3.4/iostream:45,
                  from gpcamera.cpp:35:
/usr/include/c++/3.4/cwchar:166: error: `::vfwscanf' has not been declared
/usr/include/c++/3.4/cwchar:170: error: `::vswscanf' has not been declared
/usr/include/c++/3.4/cwchar:174: error: `::vwscanf' has not been declared
/usr/include/c++/3.4/cwchar:191: error: `::wcstof' has not been declared
gmake[4]: *** [gpcamera.lo] Fel 1
gmake[4]: Leaving directory
gmake[3]: *** [all-recursive] Fel 1
gmake[3]: Leaving directory
gmake[2]: *** [all-recursive] Fel 1
gmake[2]: Leaving directory
gmake[1]: *** [all-recursive] Fel 1
gmake[1]: Leaving directory `/usr/ports/graphics/digikam/work/digikam-0.9.2'
gmake: *** [all] Fel 2
*** Error code 2

Stop in /usr/ports/graphics/digikam.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade.44474.0 en
v UPGRADE_TOOL=portupgrade UPGRADE_PORT=digikam-0.8.1_4
** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
         ! graphics/digikam (digikam-0.8.1_4)    (unknown build error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed


More information about the Digikam-users mailing list