[Digikam-users] dcraw segfault

Nicolas Vilars n.vilars at free.fr
Wed Oct 18 09:01:25 BST 2006

Gilles Caulier wrote:
> On Tuesday 17 October 2006 22:42, Mathusael wrote:
>> Hi all,
>> I'm just back from a small nightmare ;-)
>> I recently emerged/installed dcraw-8.39 and it appears that it breaks
>> badly Digikam which segfault whenever I tried to open a raw file (more
>> precisely, the editor was showing up without displaying any image, with
>> a blank screen instead and whenever I tried to click on where the image
>> would have been, Digikam was segfaulting).
>> Coming back to version 8.03 solved the problem.
>> I didn't mention it but I'm in version digikam-0.9.0_beta2(-r1 -- for
>> people using gentoo).
>> Gilles do you need me to fill a bug? a trace? already known problem/
>> fixed in svn?
>> Nicolas.
> If there is another dcraw command line options uncompatibity problem, i will 
> take a gun (:=))))  "je plaisante bien sur !!!"
> Well, digiKam 0.9.0-beta3 do not have an external dcraw depency now. We 
> include it directly ! The dcraw source code embeded in digikam core is fully 
> tested. I recommend you to try beta3 with your RAW files :
> http://digikam3rdparty.free.fr/0.9.0-beta3
> If beta3 do not solve your problem, please give my a RAW file sample, a GDB 
> backtrace and the konsole message trace.
I DID solved my problem by coming to a previous version of dcraw, so now 
everything is working under my beta2 again (it is just that it took me 
some time to figure out what was going wrong).

But YES, I will happily test the new beta3 as I have tested beta1 and beta2.
And expect to see me again if something goes wrong :-)

Nicolas Vilars
Blog - famille.vilars.com <http://famille.vilars.com>

More information about the Digikam-users mailing list