[Digikam-users] Problems compiling digikam 0.9

Duncan Hill digikam at nacnud.force9.co.uk
Wed Nov 15 19:07:17 GMT 2006


J├╝rgen Flosbach dk wrote:
> I try to compile digikam-0.9.0-beta3 and it fails.
> Configure doesn't find a few programs which are on my system.
> 
> I'm running Suse 10.0 in 64bit mode.
> 
> 
> configure output is --->
> ========================
> -- digiKam configure results -------------------
> -- sqlite3 found.................. NO
> 
> digiKam needs sqlite3. You need to install sqlite3 3.x, e.g. from
> http://www.sqlite.org
> 
> -- gphoto2 found.................. YES
> -- libkipi found.................. NO
> 
> digiKam needs libkipi. You need to install libkipi first
> libkipi website is at http://extragear.kde.org/apps/kipi
> 
> -- libtiff found.................. YES
> -- libpng found................... YES
> -- lcms found..................... YES
> -- Exiv2 library found............ YES
> ------------------------------------------------
> =============================
> 
> but, I have sqlite3 and libkipi installed. If I check my installed 
> programs with kpackage it shows me that
> 
> sqlite3 is Version 3.2.2-5
>   and installed  in /usr/bin/
>   and library is in /usr/lib64
> 
> libkipi is Version 0.1.4-5.1
>   and installed in /opt/kde3/lib64

libsqlite3-dev, libkipi-dev (or similarly named packages).  You only 
have the runtime libraries, you need the C/C++ headers.



More information about the Digikam-users mailing list