Installing dependency in order to compile digiKam

Rex Dieter rdieter at
Mon Jul 8 14:30:10 BST 2019

Fedora is (should be!) fine, it's rhel7/centos7 that's at least a minor
due to it including only Qt 5.9.x (which is no longer supported by recent
versions of KF5).

If you have other constructive criticism, I'm open to hearing it.

That said, epel7 repo has kf5-rpm-macros, I'm guessing reporter here
have that repo enabled.

On Fri, Jul 5, 2019 at 10:34 AM Gilles Caulier <caulier.gilles at>

> Le ven. 5 juil. 2019 à 09:18, Dharmendra vasadia <vasadia.kde at>
> a écrit :
>> Hello All,
>> I am installing dependencies in order to compile digiKam from
>> I want to install ecm and i went through link given on web page but dont
>> see any process how to compile and install it. Tried google followed few
>> steps but dont know how to confirm installation.
>> basically, do i need to get source of ecm, compile and install it?  or
>> just get rpm package and installed it. i tried later but it required other
>> dependency package kf5-rpm-macros
> Both are valid. In case of RPM, install just devel package.
>> rpm -Uvh extra-cmake-modules-5.52.0-1.el7.noarch.rpm
>> warning: extra-cmake-modules-5.52.0-1.el7.noarch.rpm: Header V3
>> RSA/SHA256 Signature, key ID 352c64e5: NOKEY
>> error: Failed dependencies:
>> kf5-rpm-macros is needed by extra-cmake-modules-5.52.0-1.el7.noarch
>> [root at localhost opt]# yum install kf5-rpm-macros
>> Loaded plugins: fastestmirror, langpacks
>> Loading mirror speeds from cached hostfile
>>  * base:
>>  * extras:
>>  * updates:
>> No package kf5-rpm-macros available.
> Welcome to RH/CentOS/Fedora, where KF5 support is just, a shame. Here
> under mageia, i just install right devel package et voilà all is done in
> few seconds...
> Gilles Caulier
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Digikam-devel mailing list