Smugmug web service ported to O2 : Host authentication required

Thanh Trung Dinh dinhthanhtrung1996 at
Sat Jun 2 22:49:42 BST 2018

Hi everyone, 

I'm porting digiKam web services with library O2, qt library for OAuth.
Working on Smugmug, I'm stuck with an error that I didn't understand.

Smugmug uses OAuth 1.0 as authentication method, like Flickr, so I used same
methods to login, get user data, post photos, etc. In fact, I can login and
get access token using O2 methods. I also verified that the token I got is
the right one. However, whenever I tried to use that token to get/post
something, QNetworkReply returns with error 204
(AuthenticationRequiredError) and error message : "Host authentication
required". Besides, Smugmug has endpoints that don't require token to access
(e.g GET /api/v2/user/<nickname>). So when I tried normal GET method of
QNetworkManager it worked, but when I used specific method for GET in O2
(which prepares token and other necessary headers in the url request), that
error appeared,  

Did anyone see this message error when working with authentication before? I
really appreciate any help and guide, since I am really stuck here.


Thanh-Trung Dinh    

Sent from:

More information about the Digikam-devel mailing list