[digikam] [Bug 372540] New: fileSize field in Images table limited to 4GB

Brian J Hoskins bugzilla_noreply at kde.org
Wed Nov 16 15:05:54 GMT 2016


            Bug ID: 372540
           Summary: fileSize field in Images table limited to 4GB
           Product: digikam
           Version: 5.3.0
          Platform: Kubuntu Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: Database
          Assignee: digikam-devel at kde.org
          Reporter: brian at hoskins.eu
  Target Milestone: ---

While attempting to migrate a 4.x SQLite database to mySQL I encountered the
following error:

"Error while converting the database.
Details: Out of range value for column 'fileSize' at row 1"

I have some large video files in the collection, so I checked the variable type
for the fileSize field in the Images table.  It is set to int, which means that
the largest number which can be stored is 2^32 (4GB).

To test if this was the cause, I ran the migration tool again and then after
the schema was created I manually changed the field type to bigint(64-bit)
while the migration tool was running.  This enabled digikam to process the
larger files.

To test my thinking further, I created a fresh SQLite database and added one
5.2GB mp4 file to it.  I then tried to migrate that database to mySQL and
encountered the same error.


1. Change fileSize type in Images table to bigint.
2. Enable the database migration error dialogue to print the name of the file
it was trying to process when the error was encountered.  This will make other
issues easier to identify.

You are receiving this mail because:
You are the assignee for the bug.

More information about the Digikam-devel mailing list