[Digikam-devel] [digikam] [Bug 337688] Reading/writing of keyword-tags to jpg and xmp corrupts tag hierarchy, duplicate root tag

Christian buitk14 at A1.net
Tue Jul 22 15:42:15 BST 2014


--- Comment #2 from Christian <buitk14 at A1.net> ---
More details on the way, digikam destroys tags:

It looks like two independent bugs are involved:
- duplication of root tag (for sure when writing/reading from xmp sidecar)
- duplication of parent-keywords when editing child keywords
   (e.g.  deletion, adding new childs ...)
- duplication of added keywords in digikam 4.1.0
    Up to 8 times, in most of the cases 5 times
    In most of the cases, the duplicate keywords refer to a single image
    of the album, where image-tags have been changed before.
    Only the last duplicate entry refers to most of the images 
    it was assigned to before ... see screenshot.
    In rare cases the one above the last refers to most of the images.

Why are these tags (with exactly the same name) showed many times? The
duplicates are assigned to just a few images, but there is no relation to the
changes that have been made before, except that these images are always in the
same album.

Note: I have a lot of duplicate images in different albums e.g. with different
sizes and color profiles. But duplication of tags takes place inside a single
album. Usually some images among the first 8 ones in the album view get
assigned to inconsistent key word tags with exactly the same name, but with
multiple duplicate entries in the tag hierarchy - see screen shot.

Hope this helps to track down the root cause of this severe bug (that will cost
me at least 7 working days to restore the old image databases on all my devices
- including the work of clearing the outdated tags that is lost)

More about my configuration:
- image rotation is not viewed
- all tags are written to files except "rating" and two similar items I am not
using at all
- writing to xmp sidecars is selected if "image is not writeable", and sidecars
are read
- on OpenSuse I migrated my digikam settings from 12.1 to 13.1, but I also
tried a clean setup with same results.
- the official version of digikam in OpenSuse is still 3.5. I installed 4.1
from the KDE:Extra Repository that uses release 4.1.0-11.1 for the build. Is
this a stable one?
- due to the lack of a hierarchy import/export feature, I select all
keyword-tags in a specific jpg image, and I import metadata from this image
first, e.g. when I set up a new linux work station for digikam to transfer the
hierarchy. Before import I remove the duplicate root tags from the xml file,
but I leave one root tag, otherwise the imported keywords will not match with
the imported keywords from the other jpgs.

The bugs described before are not related to this workflow ... I also tried to
import from jpgs without the special file with all the tags, and the result is
similar (bad).

You are receiving this mail because:
You are the assignee for the bug.

More information about the Digikam-devel mailing list