[Digikam-devel] [digikam] [Bug 331224] New: Sync metadata eventually slows machine to unusable state

Jeff Robinson jeffnik at anecho.mb.ca
Mon Feb 17 01:31:06 GMT 2014


            Bug ID: 331224
           Summary: Sync metadata eventually slows machine to unusable
    Classification: Unclassified
           Product: digikam
           Version: 4.0.0-beta2
          Platform: Compiled Sources
                OS: Linux
            Status: UNCONFIRMED
          Severity: crash
          Priority: NOR
         Component: Maintenance
          Assignee: digikam-devel at kde.org
          Reporter: jeffnik at anecho.mb.ca

I have a collection of RAW files that were tagged using Digikam on another
machine, the metadata written to the XMP files.  Accessing these files via a
second installation of Digikam on a laptop the second install does not read in
the XMP data.
Trying to use the Maintenance feature to sync the metadata to the database over
the network creates a moving process indicator (with no percentage/activity
text) but not activity seems to be taking place.  The hard drive on the laptop
shows activity, but eventually the system slows so much that it doesn't respond
to mouse-clicks.
I tried plugging a USB removable drive of the same images into the laptop with
the same result.
As this was a rather large collection, I pointed the maintenance tools at
different directories (including one containing only 22 images) and the same
issue occurred.

Reproducible: Always

Steps to Reproduce:
1. Select Tools -> Maintenance...
2. Select a single album.
3. Select "Sync Metadata and Database" with sync direction "From image metadata
to database"
Actual Results:  
Digikam runs but does does not complete.  The system eventually slows down to
the point where the computer has to be shut off to stop the process.

Expected Results:  
Metadata would be read in from XMP files and populate the database.

You are receiving this mail because:
You are the assignee for the bug.

More information about the Digikam-devel mailing list