[Digikam-devel] [digikam] [Bug 333299] New: crash segmentation fault at starts

Andrews andrewsroberto at gmail.com
Thu Apr 10 21:09:41 BST 2014


            Bug ID: 333299
           Summary: crash segmentation fault at starts
    Classification: Unclassified
           Product: digikam
           Version: 3.5.0
          Platform: Slackware Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: crash
          Priority: NOR
         Component: general
          Assignee: digikam-devel at kde.org
          Reporter: andrewsroberto at gmail.com

I tried run, 3.5.0, 4.0.0 beta, compiled successful 3.5 and 4.0, but still not
starting. I can't start.
bash-4.2$ digikam
Segmentation fault
bash-4.2$ gdb digikam
GNU gdb (GDB) 7.6.1
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-slackware-linux".
For bug reporting instructions, please see:
Reading symbols from /usr/bin/digikam...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/digikam 
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3600.4-gdb.py",
line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
warning: the debug information found in "/usr/lib/libqca.so.2.0.2.debug" does
not match "/usr/lib/libqca.so.2" (CRC mismatch).

Program received signal SIGSEGV, Segmentation fault.
0xb3c41b69 in strcmp () from /lib/libc.so.6
(gdb) backtrace
#0  0xb3c41b69 in strcmp () from /lib/libc.so.6
#1  0xb2afab43 in QMetaType::registerNormalizedType(QByteArray const&, void
(*)(void*), void* (*)(void const*), void (*)(void*), void* (*)(void*, void
const*), int, QFlags<QMetaType::TypeFlag>, QMetaObject const*) () from
#2  0xb2508a58 in ?? () from /usr/lib/libQt5Gui.so.5
#3  0xb2820c4d in ?? () from /usr/lib/libQt5Gui.so.5
#4  0xb2504da8 in _init () from /usr/lib/libQt5Gui.so.5
#5  0xb7fff000 in ?? () from /lib/ld-linux.so.2
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

in dmesg:
[ 9878.962833] digikam[28948]: segfault at 1188d5d0 ip b3379b69 sp bfe76834
error 4 in libc-2.17.so[b32f9000+185000]

Reproducible: Always

Steps to Reproduce:
1. start in terminal

You are receiving this mail because:
You are the assignee for the bug.

More information about the Digikam-devel mailing list