[Digikam-devel] [digikam] [Bug 257933] DigiKam zoom slider resets to minimum when returning from image preview [patch]

nurupo nurupobugskde at gmail.com
Fri May 3 23:49:12 BST 2013


--- Comment #10 from nurupo <nurupobugskde at gmail.com> ---
(In reply to comment #9)
> My suggestions would be: name the reverse of "thumbnailPixmapSize()"
> "thumbnailImageSize" or rename both to a pair of words which better
> transport the meaning.

I agree that names are confusing. What would you say about renaming
`ThumbnailLoadThread::thumbnailPixmapSize` to
`ThumbnailLoadThread::thumbnailToPixmapSize` and
`ThumbnailLoadThread::pixmapThumbnailSize` to
`ThumbnailLoadThread::pixmapToThumbnailSize`, because it's basically what they
are doing, converting pixmap size into thumbnail size and back.

> Why not patch "ThumbnailSize ImageCategorizedView::thumbnailSize() const" to
> return the actual size without border? It is
> ImageCategorizedView::setThumbnailSize(const ThumbnailSize& s) which adds
> the 2 pixels, so the same class should subtract them.

Yes, patching `ImageCategorizedView::thumbnailSize` looks like a better
solution, because logically it should return the value which was initially set,
not the value+2. But still, we can't just return size-2 from it, -2 should be
done only if thumbnail has highlight boarders.

You are receiving this mail because:
You are the assignee for the bug.

More information about the Digikam-devel mailing list