[Digikam-devel] [Bug 287772] build failed against boost-1.48 [patch]

Angelo Naselli anaselli at linux.it
Thu Jan 5 11:05:51 UTC 2012


https://bugs.kde.org/show_bug.cgi?id=287772





--- Comment #29 from Angelo Naselli <anaselli linux it>  2012-01-05 11:05:51 ---
To nucleo Comment #27 since it builds with 1.46 i suspect the problem is in a
line of the patch that report boost version, did you try to remove the "="?
#if BOOST_VERSION > 104700
        Edge(const boost::detail::reverse_graph_edge_descriptor<edge_t>& e) :
e(e.underlying_desc), null(false) {}
#endif
I'm not sure but maybe boost::detail::reverse_graph_edge_descriptor is not in
1.47.

btw, i'm testing a ugly patch that add all the changes for BOOST_VERSION >
104700
maybe you can try that one also (i will upload it as soon as i tested it).

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Digikam-devel mailing list