[Digikam-devel] [Bug 281767] digikam 2.1 will not start

Francesco Riosa francesco+kde at pnpitalia.it
Mon Sep 19 09:19:19 UTC 2011


https://bugs.kde.org/show_bug.cgi?id=281767





--- Comment #45 from Francesco Riosa <francesco+kde pnpitalia it>  2011-09-19 09:19:18 ---
> (In reply to comment #28)
> 
> Hi Francesco, 
> 
> on the Gentoo [*] bug some users have been asking about the procedure as in
> comment #28 but for the sqlite backend- any clues?
> 
> Best, Andreas
> 
> [*] https://bugs.gentoo.org/show_bug.cgi?id=382617

(In reply to comment #8)
> The instructions in the link that is provided unfortunately only apply to mysql
> databases.
> Could you please also explain the procedure for SQlite databases?
> Or is there no problem in this case?

For sqlite the procedure could be this:

1st) to be on the safe side, copy the digikam4.db thumbnails-digikam.db files
(thumbnails-digikam.db can easily be recreated but on a large collection it
take some time)

2nd) edit ~/.kde4/share/config/digikamrc, the section [Database Settings]
should contain only the following:
[Database Settings]
Database Connectoptions=
Database Hostname=
Database Name=/a/path/to/dir
Database Name Thumbnails=/a/path/to/dir
Database Password=
Database Port=0
Database Type=QSQLITE
Database Username=
Internal Database Server=false

no Image* or Thumbnails*, if these are present remove them
also check that values in there are correct.

3rd) N/A

4th) emerge -C =digikam-2.1.0-r1 && emerge -a '>=digikam-2.1.1'

Step 2) is not immediately needed but leaving the cruft there can create
problems if and when we switch to this schema of config options.
(In reply to comment #44)

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Digikam-devel mailing list