[Digikam-devel] v2.0.0 installation report

Gilles Caulier caulier.gilles at gmail.com
Mon Sep 5 16:45:37 BST 2011

2011/9/5 John Mock KD6PAG <kd6pag at amsat.org>:
> I really wanted the Versioning feature, but Debian still only has Digikam 1.9
> even in its Experimental distribution.  I have got five platforms at home,
> so i tried to see where i could make 2.0.0 work properly.  The short answer
> is none, but i was able to get something to mostly work on several platforms,
> not necessarily 2.0.0 .  I tried these in parallel intermittently over a
> period of weeks.  Mac OSX was the first platform to mostly work, followed
> by Linux.
> On a MacBook Pro running the Debian 'Testing' (amd64) distribution of Linux,
> just getting all of the prerequisites right was a bit of a challenge.  Then
> v2.0.0 didn't work very well at all, as it had trouble finding things on
> /usr/local/...  It's likely to be an oversight on my part that I couldn't
> figure out a way to change KDE's paths to include /usr/local/...  I added
> the following symbolic links, which worked around the problem:
>    ~/.kde/share/apps/digikam -> /usr/local/share/apps/digikam
>    ~/.kde/share/kde4/services -> /usr/local/share/kde4/services
>    ~/.kde/share/kde4/servicetypes -> /usr/local/share/kde4/servicetypes
> I'm not sure all of these are necessary, but 2.0.0 worked except for failing
> to do rotations from the thumbnail (or elsewhere).  Getting a more recent
> version (2.1.0) via GIT solved that problem and all the things that i've
> tried seem to be working.

Do you tried with a fresh added account to your computer, where KDE
have been just installed ?

> When the same MacBook Pro runs Mac OSX, my first attempt to install it via
> MacPorts also failed.  Installing was *extremely* slow.

All must be compiled. KDE +Qt + shared libs.

On my macbook, this take 3hours.

>I did an update a
> day later, which was alot quicker, and then it built properly.  Most things
> seemed to work, but the icons (such as rotation directions, select albums,
> select tags, etc.) are lacking (or grey).  It was the easiest, and by far
> the slowest, install.

For icons, install Oxygen ports package.

I created a small tutorial, which need to be be updated, of course. Look here :


> On a Mac Mini G4 running Debian 'Stable' distribution, initially, i could
> only get the 2.0.0-beta5(?) to build properly.  But it didn't work either.
> There, i only needed
>    ~/.kde/share/apps/digikam -> /usr/local/share/apps/digikam
> so that it could find the right database descriptors.  The earlier GIT
> version that worked on the MacBook Pro did not compile properly.  I
> upgraded to the 'Testing' distribution and added the following patch:
> --- ./core/libs/3rdparty/libpgf/Encoder.cpp.orig        2011-07-27 16:28:11.000000000 -0700
> +++ ./core/libs/3rdparty/libpgf/Encoder.cpp     2011-08-21 06:29:24.000000000 -0700
> @@ -310,7 +310,7 @@
>        // convert data
>        for (int i=0; i < wordLen; i++) {
> -               m_codeBuffer[i] = __VAL(m_codeBuffer[i]);
> +               block->m_codeBuffer[i] = __VAL(block->m_codeBuffer[i]);
>        }
>  #else
>        // write wordLen
> This made it compile and run properly on a PowerPC, albeit slowly.  That
> machine has the big screen and i'd use if the performance were to improve.

Ha, ha, this problem have been reported in Bugzilla :


I don't have backported libpgf code into digiKam core to prevent side
effect. 2.1.0 will be released soon. This will be fixed for 2.2.0.

> I tried it using Windows XP running on a virtual machine under Linux.  Being
> not directly connected to the Internet, i have not installed most security
> patches and am basically at SP3.  I tried both the KDE windows installer and
> 'digiKam-installer-2.0.0-win32.exe'.  The digiKam-installer completed, but
> the results weren't very useful.  Programs>DigiKam>DigiKam appeared to be a
> bad link, as Windows started searching for it.  Attempting to run it via
> C:\Program Files\digiKam\KDE4-MSVC\bin\digikam.exe got:
>    This application has failed to start because the application is
>    incorrect.  Reinstalling the application may fix this problem.
> Uninstalling from "Add or Remove Programs" failed to remove most of what the
> digiKam-installer added, which was under C:\Program Files\digiKam\KDE4-MSVC .
> I then tried KDE windows installer, using "Stable 4.7.0" and selecting MinGW4
> but while this completed, starting digiKam failed:
>    This application has failed to start because libgomp-1.dll was not
>    found.  Reinstalling the application may fix this problem.

Problem already reported to bugzilla :


... and recently fixed... It's a problem with KDE windows installer.

> A quick web search didn't find any good leads on how to work around this.
> So i tried selecting MSVC instead.  (By the way, the KDE uninstaller did
> not do much better than the digikam-installer and i had to get rid of a
> similar directory 'by hand'.)  Re-installing got me:
>    Run-time Qt4 QSLite or MySQL database plug-in is not available - please
>    install it.  There is no database plugin installed on your computer.

MSVC compiler version is better than MinGW, because some windows API,
are missing with GCC for Windows.

MSVC compiler binary is smaller than M$ version. Again it's GCC for
windows which is not yet optimized.

> So perhaps 'digiKam' doesn't request all the right libraries in the KDE
> windows installer??  But there was no selection under the installer for
> SQLite, either.  So i tried installing 'krecipes', which i guessed might
> include SQLite (and selected that option during its configuration).  No
> help, even though 'krecipes' seem to start up and display a sample recipe.
> Maybe it's a path issue, as 'C:\Program Files\KDE\bin\sqlite3.dll' exists
> (as does 'C:\Program Files\KDE\plugins\sqldrivers\sqlite4.dll')??

Anyway your problem with DB Qt plugin must be reported to KDE windows
team, through KDE bugzilla. It's not a digiKam bug. It's an
installation problem...

> [Earlier, i had also tried on a Sony PCG-R505EL running Windows XP with
> lots of things already loaded, but didn't take notes on how i got as far
> as i did with that one.  It almost worked, but none of the images would
> display under Tags and i think it had some other forms of path confusion.
> So running under Windows seems possible, but maybe not so repeatably.]

This is a kioslave problem. Install can be wrong, or KDE runtime
components can be missing.

I agree that installation is problematic under windows. In fact more
test, hack and report need to be done.

> I also have Debian Linux (i386) running on the Sony and would try that
> platform if there's interest, as i plan to retire that machine soon.
> So that's my 2.0.0 installation report.  I'll post more later if/when i
> get some more experience with it.

Note : with 2.1.0 released soon, more than 50 bugs have been fixed. If
you plan to test digiKam again, please try this version :


Also, into kipi-plugins 2.1.0, a new important tool have been added :
a panorama stitcher :



Gilles Caulier

More information about the Digikam-devel mailing list