[Digikam-devel] [Bug 281320] New: Errors in subtag handling in Peoples-Browser

Arnd kde-bugs at hanamana.de
Sun Sep 4 13:47:31 UTC 2011


https://bugs.kde.org/show_bug.cgi?id=281320

           Summary: Errors in subtag handling in Peoples-Browser
           Product: digikam
           Version: 2.0.0
          Platform: Archlinux Packages
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: Face Detection
        AssignedTo: digikam-devel at kde.org
        ReportedBy: kde-bugs at hanamana.de


Version:           2.0.0 (using KDE 4.7.0) 
OS:                Linux

Tags created with Right-Mouse-Button->New Tag... on  people don't show up in
tag list.

A work around via tags-browser shows another error (details in steps to
reproduce).

Reproducible: Always

Steps to Reproduce:
Example use case: I have created peoples a, b and c and tagged some faces. Now
I want to put tags a, b and c as sub-tags into tag "family x", which does not
exist so far. So in the peoples-browser I right click on top level tag
"people", select "new tag" and enter "family x". The new tag is created but
does not show up in the list. Restarting Digikam does not help at this point.

Work around: Next I go to the tags-browser, where my new tag is visible. I move
tags a, b and c via drag and drop into the "family x" tag. Going back to the
peoples-browser, "family x" is still not visible. Restarting Digikam at this
point helps: "family x" together with subtags a, b and c are now visible in the
peoples-browser.

Moving tags as subtags to other tags inside the peoples-browser works, once you
can see the destination.


Expected Results:  
Subtag handling in peoples-browser and tags-browser should work consistently
and concurrently.

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Digikam-devel mailing list