[Digikam-devel] [Bug 270159] Tag replaced instead of added

Rinus Bakker sleeplessregulus at hetnet.nl
Wed May 25 12:28:13 BST 2011


--- Comment #4 from Rinus Bakker <sleeplessregulus hetnet nl>  2011-05-25 13:28:12 ---
Op 25-05-11 12:18, Francesco Riosa schreef:
> https://bugs.kde.org/show_bug.cgi?id=270159
> Francesco Riosa<francesco+kde at pnpitalia.it>  changed:
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |francesco+kde at pnpitalia.it
> --- Comment #3 from Francesco Riosa<francesco+kde pnpitalia it>   2011-05-25 12:18:24 ---
> (In reply to comment #1)
>> Cannot reproduce. Anyone?
> Idem, on Mysql and latest git, tried 3 levels
> (In reply to comment #2)
> What backend are you using? sqlite or mysql? in the latter case could you try
> latest git sources?
> Thank you

Build from git two days ago (fresh enough?)
I use SQlite
It still happens

see attachments
Tag 1 applied
Tag 2 applied

¨She¨ replaced instead of added. ¨Me¨ has gone.

Interestingly, if I drag from filters view there is no dialogue

¨You have edited the tags of the image. Do you want to apply your changes?¨
so, there does not the replacement take place but it applies only the 
child and not the parent, very confusing this inconsistent behaviour.
And even more confusing after I dragged from filters view the 
¨captions/tag¨ view mimicked the behaviour of the ¨Filters¨ view and I 
had to restart digikam to go back to normal. (My suggestion is anyway to 
disable the drag function from ¨filter¨ view)

I can see it will be very hard to get this issues solved. But as photo
managing and thus tagging is the core bussiness from digikam I hope for
the best.


Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the Digikam-devel mailing list