[Digikam-devel] [Bug 272158] New: wish: more user feedback about background operations

Thomas Eschenbacher Thomas.Eschenbacher at gmx.de
Sun May 1 15:44:15 CEST 2011


           Summary: wish: more user feedback about background operations
           Product: digikam
           Version: 2.0.0
          Platform: Gentoo Packages
        OS/Version: Linux
            Status: NEW
          Severity: wishlist
          Priority: NOR
         Component: Usability
        AssignedTo: digikam-devel at kde.org
        ReportedBy: Thomas.Eschenbacher at gmx.de

Version:           2.0.0 (using KDE 4.6.2) 
OS:                Linux

Some operations which are running in background do not give any visible
feedback to the user and give a wrong impression about their state. Here just
an example:

Reproducible: Always

Steps to Reproduce:
* enter an existing album an select an image
* copy the image (Ctrl-C)
* create a new / empty album and enter it
* paste the image (Ctrl-V)

Actual Results:  
For several seconds nothing seems to happen: no progress bar, no hourglass
cursor, just no visible reaction. You can use the program, navigate, or
whatever - still having an empty album on the screen.

Then if if you ask myself "did i really press Ctrl-V?" and press it again,
digikam complains that the image already exists - while still showing an empty

Expected Results:  
While things are running in background, the affected "target" should be locked
(e.g. by setting the hourglass cursor on the target of a drag&drop or a paste
operation) or maybe a "placeholder" should be put into the target view.

This happened for other operations as well, e.g. when assigning names to
several images (in context of face tagging, assigning in People/Unknown) - then
the view and the model behind seem to get out of sync for quite a while and
continuing to work can produce damage by applying operations to wrong items.

The only kind of "feedback" I get comes from watching the CPU load in
So for all album operations and all operations that affect multiple items, I
can only do them by starting a task, wait for several seconds, watching the cpu
load, and then continue with the next task.

NOTE: This might also be related to some existing bugs, e.g.

Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the Digikam-devel mailing list