[Digikam-devel] Please tell me how to compile digikam with exiv2 and kdcraw libraries

Simon Eugster simon.eu at gmail.com
Mon May 17 21:21:16 CEST 2010


2010/5/16 Jens Müller <tschensinger at web.de>:
> Am Sonntag, 16. Mai 2010, um 20:10:33 schrieb digikam-devel-request at kde.org:
>> Thanks for your answer! I'm on a 64bit system, indeed. Which paths do I
>> have to adjust?
>>
>> And yes,  I've installed everything to /usr/local, not to /usr.
>>
>> Simon
>
>
> Simon,
>
> I think these two lines in the script have to be for your system:
> export LD_LIBRARY_PATH="$DIGIKAMDEST/lib:$DIGIKAMDEST/lib64/kde4:
> $DIGIKAMDEST/lib64:$LD_LIBRARY_PATH"
> export LDPATH="$DIGIKAMDEST/lib:$DIGIKAMDEST/lib64/kde4:$DIGIKAMDEST/lib64:
> $LD_LIBRARY_PATH"
>
> Could you try it?

Sorry, I just noticed that I was mistaken. My laptop is 64bit, and
there it's working (I didn't remove digikam before). On my PC, which I
use for managing my photos, I'm still running a 32bit linux.
Second thing is, both use .../lib/ and not .../lib64/.

Simon


More information about the Digikam-devel mailing list