[Digikam-devel] [Bug 229234] thumbnail mismatch for images with same name

Tom Malfrere tom.malfrere at pandora.be
Thu Jun 10 14:56:46 CEST 2010


https://bugs.kde.org/show_bug.cgi?id=229234


Tom Malfrere <tom.malfrere at pandora.be> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |tom.malfrere at pandora.be




--- Comment #4 from Tom Malfrere <tom malfrere pandora be>  2010-06-10 14:56:45 ---
Same problem here!

I have 2 cameras (Canon 300D and 550D). OpenSuse 11.2 with digikam 1.0.0 and
1.2.0.

I have a Synology network HD thats fetches my images from my cameras. 
First I copied my images from my 550D to my network HD. Then I copied these
foto's to my 'new' folder on my laptop (OpenSuSE 11.2). Then I opened digikam
1.0.0. All thumbnails were OK. I created some new folders and sorted all the
fotos from my 550D into these folders. I ended with an empty 'new' folder.

Then my synology copied these fotos from my 300D camera. I copied these images
into my 'new' folder. I opened digikam (1.2.0). 
Some of the images had a wrong thumbnail. Images with the same name as images
from my 550D camera had the wrong thumbnail! 
viewing the full image or the preview gave the correct image (different from
thumbnail).
Selecting an other folder and back did not help.
Pressing F5 did not help.
Thumbnail rebuild (Quick) did not help.
Closing digikam and reopening did not help.
Closing dikikam renaming the images and reopening digikam did not help. The
images now had a different name, but still the thumbnails were wrong.

I upgraded my KDE from 4.3.5 to 4.4 and digikam from 1.0.0 to 1.2.0
I opened digikam and still the thumbnails were wrong.

I finally resolved the problem by deleting the thumbnail.db (not sure about the
correct name) in my home folder.

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Digikam-devel mailing list