[Digikam-devel] digikam 1.3.0 build issues.

Andi Clemens andi.clemens at gmx.net
Wed Jun 9 07:30:06 CEST 2010


Archlinux does so, too, but these are just two distributions.
I also liked the old way a lot better, where we released the libs by 
ourselves. Now most major distributions constantly have problems updating 
digiKam, since their release plan doesn't match the one of KDE.

Andi Clemens
-----------------
www.digikam.org

On Wednesday 09 June 2010 00:26:20 Gilles Caulier wrote:
> 2010/6/9 Mark Purcell <msp at debian.org>:
> >> Just compile and install libkdcraw/libkexiv2 (and also libkipi) from
> >> svn trunk (kdegraphics module)
> > 
> > Gilles,
> > 
> > Unfortunately for a distribution such as Debian we are tied to releases
> > of the kdegraphics module. We can't easily include the svn trunk
> > components of some of kdegraphics :-(
> > 
> >> all library code are managed by digiKam team.
> > 
> > The libraries maybe managed by the digikam team, but the release is
> > controlled by the kdegraphics release, do you know which release the
> > updates are slated for?
> 
> KDE 4.5.
> 
> > I would doubt that KDE SC 4.4.5 will include large changes, which means
> > we maybe awaiting KDE SC 4.5 for updates to these libs.
> > 
> > Previously when the digikam team released these libraries directly, we
> > could update the library packaging independent of the upstream
> > kdegraphics release, however we cannot do that anymore.
> > 
> > I presume that other distributions would also have the same issues?
> 
> I know that Mandriva include kdegraphics/libs from trunk as well...
> 
> Gilles
> _______________________________________________
> Digikam-devel mailing list
> Digikam-devel at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-devel


More information about the Digikam-devel mailing list