[Digikam-devel] [Bug 259057] Crash when reading one particular image (possibly libexiv2 related)

Davide Orlandi davide at davideorlandi.it
Wed Dec 8 20:33:39 GMT 2010


--- Comment #8 from Davide Orlandi <davide davideorlandi it>  2010-12-08 21:33:33 ---
Sorry, I'm not experienced enough to switch a library. I installed 0.20 but
digikam still uses 0.19.3.
[by the way: in the main text of the bug I wrote "...but the crash happens with
0.20 too": I was *wrong*, I installed 0.20 but didn't know digikam was still
using 0.19.3]

I tried to remove 0.19.3 but the network of dependencies would uninstall almost
everything else, including digikam. Finally I tried to change the symbolic link
for libexiv2.so.6 pointing it to libexiv2.so.9.0.0 (the new one) but when I ran
digikam I got an "undefined symbol" error.

It seems I'll have to wait until the next ubuntu release in april.

That picture is not really a problem for me (I can simply re-save it with gimp
and after that digikam can read it); I opened the bug just to help improve the

Anyway you can still check if the latest version crashes or works by saving the
attached image and trying yourself.

Thank you for your patience and great work.

Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the Digikam-devel mailing list