[Digikam-devel] Commit 1018320 requires Qt 4.5

Andi Clemens andi.clemens at gmx.net
Wed Sep 2 09:52:15 CEST 2009


I will fix this... when I use autocompletion, it doesn't show me if it is Qt 
4.5 only :-)

Andi

On Wednesday 02 September 2009 09:44:37 Matti Rintala wrote:
> I only have Qt 4.4.3 installed, and couldn't compile the trunk today.
>
> Problem:
>
> digikam/graphics/digikam/utilities/manualrename/parsers/metadataparser.cpp:
> In member function 'virtual void
> Digikam::ManualRename::MetadataParser::slotTokenTriggered(const QString&)':
> digikam/graphics/digikam/utilities/manualrename/parsers/metadataparser.cpp:
>109: error: 'class QHBoxLayout' has no member named 'setStretch'
>
> That line was introduced by commit 1018320
>
> According to Qt API docs, QHBoxLayout::setStretch exists in Qt 4.5 but
> not in 4.4.3. Is Qt 4.5 going to be a requirement or should this be fixed?


More information about the Digikam-devel mailing list