[Digikam-devel] [Bug 198316] New: Text of disabled button doesn't appear as "disabled" on Qt apps when color scheme is used

hcoohb at gmail.com hcoohb at gmail.com
Mon Jun 29 19:09:02 CEST 2009


https://bugs.kde.org/show_bug.cgi?id=198316

           Summary: Text of disabled button doesn't appear as "disabled"
                    on Qt apps when color scheme is used
           Product: digikam
           Version: unspecified
          Platform: Fedora RPMs
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: Themes
        AssignedTo: digikam-devel at kde.org
        ReportedBy: hcoohb at gmail.com


Version:            (using KDE 4.2.4)
OS:                Linux
Installed from:    Fedora RPMs

When a different scheme color is set, the text of disabled buttons on Qt apps
is no more disabled (the text appear as if the button was enabled).
This is only on Qt apps and no on kde apps.

How to reproduce :
- change color scheme in systemsettings and apply
- open an qt apps (ex: Arora) and see that text of disabled buttons is wrong
(ex: in arora go on Windows>downloads>Clean up and then "clean up" should be
disabled).

How to fix it :
I found a way of fixing it but I don't know if it is the proper.
Edit ~/.kde/share/config/kdeglobals and in the category [Colors:Button],
remove the line : ForegroundNormal=0,0,0

Indeed, a lot of scheme files have this line. I don't know what is the meaning
of this line but it makes qt apps button wrongs !

I have seen that some of the scheme color files for 4.3 still have this line.
Is the bug still present in 4.3? Because that would be awesome if it was fixed
before the release.

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Digikam-devel mailing list