[Digikam-devel] Template identification after camera download don't work...

Gilles Caulier caulier.gilles at gmail.com
Fri Jun 26 10:14:10 CEST 2009


Marcel,

Since your commit yesterday evening, something is broken.

Open camera GUI, and set a template to apply. Download an item.
Template info are applied to XMP.

Now go to target album and select item. In Caption and Tags, Template
applied to image must be selected in combobox, but it's not the case.

With my last debug statement, i can see :

digikam(25834)/digikam (core) Digikam::Template::operator==: ("Linus")
("Linus") true
digikam(25834)/digikam (core) Digikam::Template::operator==: "Linux
kernel coordinator" "Linux kernel coordinator" true
digikam(25834)/digikam (core) Digikam::Template::operator==: "Linux
team" "Linux team" true
digikam(25834)/digikam (core) Digikam::Template::operator==: "(C)
Linus Torvalds - 2009" "(C) Linus Torvalds - 2009" true
digikam(25834)/digikam (core) Digikam::Template::operator==: "" "GPL"
false
digikam(25834)/digikam (core) Digikam::Template::operator==:
"www.kernel.org" "www.kernel.org" true
digikam(25834)/digikam (core) Digikam::Template::operator==:
"www.kernel.org" "To be distributed over the world" false

Template title applied to my image is "Linus" of course. Not all
properties are not egal here, but in XMP, all is fine.

Note : From icon view, select an item, remove XMP, go to caption and
tags and apply a template. leave icon view item focus and go back :
template is found properly...

Gilles


More information about the Digikam-devel mailing list