[Digikam-devel] Broken Caption field

Andi Clemens andi.clemens at gmx.net
Mon Jun 22 15:54:53 CEST 2009


Hmm still the same? Maybe we are talking about different things ;-)
But when I enter an updated caption, the "apply" button is greyed out.
So I need to press "update" first and then "apply".

Andi

On Monday 22 June 2009 14:00:36 Gilles Caulier wrote:
> Try #985220
>
> Gilles
>
> 2009/6/22 Gilles Caulier <caulier.gilles at gmail.com>:
> > 2009/6/22 Andi Clemens <andi.clemens at gmx.net>:
> >> ? When I revert to the previous state (before the update button), I only
> >> need to press one button.
> >>
> >> For example my caption is "Bla" for an image. I select this image, type
> >> "Bla2" in the caption and press apply.
> >
> > well, i don't understand how it's possible. From ImageDescEditTab :
> >
> >
> >    connect(d->captionsEdit, SIGNAL(signalModified()),
> >            this, SLOT(slotCommentChanged()));
> >
> >
> > signalModified() is emit only when Add or Del button are pressed...
> >
> > I don't have changed thios part with my commit.
> >
> >> With the new "update" button I type "Bla2", press "update" and then
> >> "apply", otherwise the caption is not set.
> >
> > For me it's logic with current code.
> >
> > If i emit this signal when you modify caption text without to press
> > Add button, nothing will be assigned to a language.
> >
> > Perhaps we can assign it to x-default by default to improve workflow...
> >
> > Gilles
>
> _______________________________________________
> Digikam-devel mailing list
> Digikam-devel at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-devel



More information about the Digikam-devel mailing list