[Digikam-devel] [Bug 153070] search for image by geo location

tackat at kde.org tackat at kde.org
Thu Jun 5 08:07:39 BST 2008

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From tackat kde org  2008-06-05 09:07 -------
Ok, sorry if it looks a bit like nitpicking but selections are really something that I'd like to see well-done right from the start.

I'd like to have the signal you're emitting changed a bit:

Currently it's called "newSelection" which uses the C++ keywords "new" and doesn't stick to the Qt naming scheme of things. What about naming the signal 

void regionSelected( QList<double> coords ) 

or emitting simply a 

void selectionChanged()

and letting the application retrieve through another method "QList<double> selection() const" what area is actually selected.

BTW: how does your method cover deselection?

> About point #2, here QRubberBand performance drawing are fine here (Qt 4.3.3).

Great :-) Just wanted to have feedback whether it works fine. So forget about it.
> About #3 : yes, this can be optimized. In fact 
> MarbleWidgetInputHandler code need to be fully re-writted... 

Yes, this is known but I haven't had the time to take care of it. Do you have any suggestions how MarbleWidgetInputHandler should look like in the future and what would you like to see changed about it?

More information about the Digikam-devel mailing list