[Digikam-devel] [Bug 155054] New: misleading error messages regarding too old libkexiv2

MichaƂ Kosmulski mkosmul at users.sourceforge.net
Thu Jan 3 22:25:05 GMT 2008

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: misleading error messages regarding too old libkexiv2
           Product: digikam
           Version: unspecified
          Platform: Slackware Packages
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: setup
        AssignedTo: digikam-devel kde org
        ReportedBy: mkosmul users sourceforge net

Version:           0.9.3 (using KDE KDE 3.5.7)
Installed from:    Slackware Packages
Compiler:          gcc (GCC) 4.1.2 
OS:                Linux

When running ./configure for digikam 0.9.3, I ran into an error message saying my libkexiv2 is too old, as at least 0.1.5 was required:

-- libkexiv2 library found........ NO

digiKam needs libkexiv2 library >= 0.1.5. You need to install libkexiv2 first
libkexiv2 website is at http://www.kipi-plugins.org

However, I did have 0.1.5 installed. This message appear near the very end of configure's output. After some time, I found out, that earlier in the tons of messages produced by configure, there was a notice that version 0.1.6 was required. After updating libkexiv2 to 0.1.6, the problem disappeared, however the original messag ecaused a lot of confusion as a different version was printed out than was really required (and the earlier message with the correct version was not easy to spot).

More information about the Digikam-devel mailing list