[Digikam-devel] [Bug 148105] problems with albums who's name start as the album library path

George B george at avramoiu.ro
Sun Jul 22 21:10:48 BST 2007

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From george avramoiu ro  2007-07-22 22:10 -------
I tried with the version from repos (0.9.2-final) and it's the same; I tried compiling it from svn, but after two hours I gave up. 

Last name the folder had was "nunta_Erol"; after installing the new version I started digikam and everything was ok; I closed it, and "mv nunta_Erol/ poze_nunta_Erol"; when I started digikam it asked for confirmation to delete the album "nunta_Erol" because it was removed from the disk, then it scanned the library, and asked for confirmation to delete a big list of pics from the "_nunta_Erol" album because they are not on the disk; so at least at the startup scan, it can see the folder; but I think there's a problem with its database. 

The folder was copied using scp from the other maching and at file system level everything was ok (no multiple folders, etc).

I did another test, I created a folder "/pics", change the library path to this folder, closed digikam, created a sub-folder "pics album" and copied a picture there, then opened digikam.. same problem; I attached two screenshots.

root mormy:/usr/lib# mkdir /pics
root mormy:/usr/lib# chown georgeav:georgeav /pics
georgeav mormy:/poze$ mkdir /pics/pics\ album
georgeav mormy:/poze$ cp ./poze_nunta_Erol/img_5609.jpg /pics/pics\ album/


Also, on another system I have the library path in /arhive/everyone/digikam ; I tried creatin an album "arhive everyone digikam new" and "arhive\everyone\digikam new" and it was ok, no problem (I couldn't create "arhive/everyone/digikam new" :-) ). So I think this problem is only if the library path is a folder in the root folder.

More information about the Digikam-devel mailing list