[Digikam-devel] [Bug 153716] New: Digikam does not work with Olympus C-170 CAMEDIA camera

Julio A.Cartaya jacartaya at computatio.com
Sun Dec 9 11:36:22 GMT 2007

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: Digikam does not work with Olympus C-170 CAMEDIA camera
           Product: digikam
           Version: unspecified
          Platform: unspecified
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: digikam-devel kde org
        ReportedBy: jacartaya computatio com

Version:           0.9.2-final (using KDE 3.5.7, compiled sources)
Compiler:          Target: i586-mandriva-linux-gnu
OS:                Linux (i686) release

My Olympus C-170 Camedia camera used to be misidentified by Digikam as an Olympus C-370Z, but at least it worked. Now it reports it can not read the "/" directory of the camera, and that is all.

Obviously, I am doing all the prep work with the camera the same way I used to do: putting it in the "P" mode, connecting the same USB cable I used to, and the rest.

I tried several other settings, like "USB PTP Class Camera" and "Directory Browse" and it does not work either.

Perhaps the problem is not Digikam, but the USB drivers under Linux, because as of 1 month ago I installed Mandriva 2008 and the new kernel is, and now if I use the "Storage Media" KDE interface to access the USB device directly, it gives the error message "Could not read file Error writing to the port".

So, essentially, my camera has become useless under Linux.

More information about the Digikam-devel mailing list