Review Request 119496: Log explicitely why a product was dropped

Friedrich W. H. Kossebau kossebau at kde.org
Sun Jul 27 17:25:31 BST 2014



> On Juli 27, 2014, 4:10 nachm., Elvis Stansvik wrote:
> > cmake/modules/CalligraProductSetMacros.cmake, line 43
> > <https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line43>
> >
> >     maybe use unset(..) instead? it's a little clearer i think. at least i had to consult the cmake docs to realize set(..) actually unsets when no value is passed in :)

unset() might be better to use, yes, good hint. Did not know it exists and got used to set() already :)
Will keep in mind and the next weeks prepare a cleanup patch for all those cases were unset() could be used instead of set() (unless someone beats me to it ;) )


> On Juli 27, 2014, 4:10 nachm., Elvis Stansvik wrote:
> > cmake/modules/CalligraProductSetMacros.cmake, line 37
> > <https://git.reviewboard.kde.org/r/119496/diff/1/?file=293440#file293440line37>
> >
> >     is this necessary? it just unsets ${_current_flag} right? (which has never been set at this point).

Not necessary right now, yes. But it is done to protect against any other code starting to use a var with that very name. Sadly there seems no way to limit the scope of vars to functions in CMake 2.x (AFAIK).


- Friedrich W. H.


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/119496/#review63263
-----------------------------------------------------------


On Juli 27, 2014, 3:55 nachm., Friedrich W. H. Kossebau wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/119496/
> -----------------------------------------------------------
> 
> (Updated Juli 27, 2014, 3:55 nachm.)
> 
> 
> Review request for Calligra.
> 
> 
> Repository: calligra
> 
> 
> Description
> -------
> 
> The current build system is slightly unprecise about which external dep is missing, there is only one generic string for each product if one or more of the external deps was/were missing. E.g. "libodfgen|libetonyek|librevenge devel not found" or "SharedMimeInfo|libeigen3|libexiv2|lcms|boost-system devel not found".
> 
> This patch changes that by adding a new macro "calligra_drop_product_on_bad_condition" and adapting the current product-dropping-due-to-bad-external-deps code. As side effect it gives a nice listing of external deps for each product.
> 
> Any better name for "calligra_drop_product_on_bad_condition"?
> 
> (Also brings consistent handling of Xinput_FOUND as TRUE for Windows and OSX)
> 
> 
> Diffs
> -----
> 
>   CMakeLists.txt f76746c 
>   cmake/modules/CalligraProductSetMacros.cmake bdca16c 
> 
> Diff: https://git.reviewboard.kde.org/r/119496/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Friedrich W. H. Kossebau
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/calligra-devel/attachments/20140727/31f939fb/attachment.htm>


More information about the calligra-devel mailing list