Review Request 111914: Add support for annotations, a.k.a. notes, to Words and Author

Inge Wallin inge at lysator.liu.se
Tue Aug 27 22:00:19 BST 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/111914/#review38763
-----------------------------------------------------------


Except for the lack of commands for inserting and deleting annotations, we are getting into nitpick area now.  Still some testing to do though.


ANNOTATIONS-ODF
<http://git.reviewboard.kde.org/r/111914/#comment28615>

    Shall we support moving annotations around? svg:{x,y,width,height} suggests that it is intended.  But I think it's a bad idea.  Comments?



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28616>

    remove unused include



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28617>

    magic number.  Besides, if this is really the x coordinate, this is totally wrong.  What if the page is of another size?  Or in landscape mode?



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28618>

    brace position wrong
    



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28619>

    iterators are mostly called it, not i.  The name i is used for an index.
    



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28620>

    magic numbers.  Besides, what is "viewMode content size height"?



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28621>

    brace position
    



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28622>

    iterator = "it"



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28623>

    iterator = "it"



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28624>

    what color is this?  What is it used for?  Comments, please.



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28625>

    iterator = "it"
    
    Also: why constBegin and not constEnd?



libs/flake/KoAnnotationLayoutManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28628>

     - spelling: connection, connectionPoint
     - Capital letter starting a sentence
    



libs/flake/KoShapeController.h
<http://git.reviewboard.kde.org/r/111914/#comment28629>

    APIdocs



libs/flake/KoShapeController.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28631>

    Not needed since it returns 0 if it is 0. :)



libs/flake/KoShapeManager.h
<http://git.reviewboard.kde.org/r/111914/#comment28633>

    Why only annotation shape? This could be emitted for any shape that is removed.



libs/flake/KoShapeManager.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28634>

    name



libs/kotext/KoAnnotation.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28635>

    I think the mode variable should be an enum and not a bool.



libs/kotext/KoTextEditor.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28639>

    VERY IMPORTANT:  We need an AddAnnotationCommand that inserts an annotation.  Otherwise adding an annotation is not undo-able.
    
    The same goes for DeleteAnnotationCommand.



libs/textlayout/KoTextDocumentLayout.h
<http://git.reviewboard.kde.org/r/111914/#comment28640>

    APIdocs



words/part/KWCanvasBase.h
<http://git.reviewboard.kde.org/r/111914/#comment28641>

    Better name is annotationsShown()?



words/part/KWOdfWriter.cpp
<http://git.reviewboard.kde.org/r/111914/#comment28642>

    It's time to do this now.


- Inge Wallin


On Aug. 24, 2013, 5:38 a.m., Inge Wallin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/111914/
> -----------------------------------------------------------
> 
> (Updated Aug. 24, 2013, 5:38 a.m.)
> 
> 
> Review request for Calligra.
> 
> 
> Description
> -------
> 
> This patch adds support for annotations to Words and Author. 
> 
> NOTE: We are aware that this patch is not yet ready for merge.  The review request is as much for ourselves (ingwa, moji, boemann) as for others.
> 
> The patch is large and rather complex so we use the review board to get an overview of the changes and to see early what we need to fix. There are still a number of bugs and not 100% of the features that we want to support are implemented.
> 
> All of this said, annotations basically work now and you can check out the branch text-annotation if you want to test it. We would like to get some feedback already now so we can fix the issues early and provide a cleaner patch once we have finished the feature completely.
> 
> 
> Diffs
> -----
> 
>   ANNOTATIONS-ODF PRE-CREATION 
>   TODO-ANNOTATIONS PRE-CREATION 
>   libs/flake/CMakeLists.txt 7d03157 
>   libs/flake/KoAnnotationLayoutManager.h PRE-CREATION 
>   libs/flake/KoAnnotationLayoutManager.cpp PRE-CREATION 
>   libs/flake/KoShapeController.h 2ae03ca 
>   libs/flake/KoShapeController.cpp 817ba5e 
>   libs/flake/KoShapeManager.h 9df1671 
>   libs/flake/KoShapeManager.cpp 36666ce 
>   libs/kotext/KoAnnotation.h c4457fd 
>   libs/kotext/KoAnnotation.cpp e5a8a53 
>   libs/kotext/KoTextEditor.h 9fd3c05 
>   libs/kotext/KoTextEditor.cpp 40ac427 
>   libs/kotext/KoTextRangeManager.cpp fdde8ee 
>   libs/kotext/opendocument/KoTextLoader.cpp 7831109 
>   libs/textlayout/KoTextDocumentLayout.h a0fabcf 
>   libs/textlayout/KoTextDocumentLayout.cpp 1eec452 
>   plugins/textshape/AnnotationTextShape.h PRE-CREATION 
>   plugins/textshape/AnnotationTextShape.cpp PRE-CREATION 
>   plugins/textshape/AnnotationTextShapeFactory.h PRE-CREATION 
>   plugins/textshape/AnnotationTextShapeFactory.cpp PRE-CREATION 
>   plugins/textshape/CMakeLists.txt 1838cf1 
>   plugins/textshape/ReviewTool.h e2b8f95 
>   plugins/textshape/ReviewTool.cpp 53c87c7 
>   plugins/textshape/SimpleRootAreaProvider.cpp 30a74ab 
>   plugins/textshape/TextPlugin.cpp b99243f 
>   plugins/textshape/TextTool.cpp 0afc19f 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.h PRE-CREATION 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.cpp PRE-CREATION 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.ui PRE-CREATION 
>   words/part/KWCanvas.cpp f33d993 
>   words/part/KWCanvasBase.h 31111ce 
>   words/part/KWCanvasBase.cpp 22d1c5f 
>   words/part/KWDocument.h 7654aa3 
>   words/part/KWDocument.cpp 259fd4e 
>   words/part/KWOdfSharedLoadingData.cpp 450b580 
>   words/part/KWOdfWriter.cpp 1675bf1 
>   words/part/KWView.h 517cbc1 
>   words/part/KWView.cpp 48265fd 
>   words/part/KWViewModeNormal.cpp 88e67b2 
>   words/part/frames/KWTextFrameSet.cpp 1bb513c 
>   words/part/words.rc 31cabbd 
> 
> Diff: http://git.reviewboard.kde.org/r/111914/diff/
> 
> 
> Testing
> -------
> 
> Created test files in LO with annotations and loaded them.  Also created our own test files.
> 
> 
> Thanks,
> 
> Inge Wallin
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/calligra-devel/attachments/20130827/26781574/attachment.htm>


More information about the calligra-devel mailing list