Review Request: Changing from QMaps to QLists in createOptionWidgets()

Thorsten Zachmann t.zachmann at zagge.de
Fri May 20 04:58:45 BST 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/101384/#review3414
-----------------------------------------------------------


Please put only the stuff that is needed in the review request.


braindump/plugins/stateshape/StateTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2861>

    Can you please move the { into the next line. I know you did not do that but as you are changing the line never the less it would be nice if you could do it.



braindump/plugins/webshape/WebTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2862>

    The { should be in the same line as the while/if.
    After if there shoul dbe a blank



karbon/plugins/tools/KarbonPatternTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2863>

    Please remove the trailing space.



krita/plugins/tools/defaulttools/kis_tool_path.cc
<http://git.reviewboard.kde.org/r/101384/#comment2864>

    Can you please rename the variable map to widgets as map is very misleading now.



libs/kopageapp/tools/backgroundTool/KoPABackgroundTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2865>

    Is the removal of the name wanted?



libs/main/KoMainWindow.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2866>

    Please use const_iterator. Or is there a reason to not use it?



libs/main/KoMainWindow.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2867>

    The opening { should be in the same line as while/if. Indenet should be 4 spaces.



libs/main/KoMainWindow.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2868>

    The opening { should be in the same line as while/if. Indenet should be 4 spaces.



libs/main/KoToolDocker.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2869>

    Is the change to a non const iterator needed?



libs/main/KoToolDocker.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2870>

    Instead of (*iter)-> it is simpler to write iter-> which is the same.



plugins/artistictextshape/ArtisticTextTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2871>

    Can you please remove all the trailing spaces marked with red in the review.



plugins/defaultTools/connectionTool/ConnectionTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2872>

    The variable name should start with a lower case so it should be connectionPoint instead of ConnectPoint.



plugins/defaultTools/defaulttool/DefaultTool.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2873>

    Please start variable names with lower case as UpperCase marks classes.



tables/ui/CellToolBase.cpp
<http://git.reviewboard.kde.org/r/101384/#comment2874>

    These changes should not be part of these fix.


- Thorsten


On May 18, 2011, 6:23 p.m., Samuel Buttigieg wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/101384/
> -----------------------------------------------------------
> 
> (Updated May 18, 2011, 6:23 p.m.)
> 
> 
> Review request for Calligra.
> 
> 
> Summary
> -------
> 
> As requested by boemann, this patch replaces all instances of QMaps used to represent Widgets with QLists. Using QLists allows the widgets to be displayed in the order you like them to.
> 
> 
> Diffs
> -----
> 
>   CMakeLists.txt ddcd01f 
>   braindump/plugins/stateshape/StateTool.h 7ab14cb 
>   braindump/plugins/stateshape/StateTool.cpp 79d7927 
>   braindump/plugins/webshape/WebTool.h 2998d09 
>   braindump/plugins/webshape/WebTool.cpp 44901ae 
>   karbon/plugins/tools/KarbonGradientTool.h bb87f8f 
>   karbon/plugins/tools/KarbonGradientTool.cpp 02718b0 
>   karbon/plugins/tools/KarbonPatternTool.h f9792a0 
>   karbon/plugins/tools/KarbonPatternTool.cpp 51e57dd 
>   karbon/plugins/tools/filterEffectTool/KarbonFilterEffectsTool.h a25b54e 
>   karbon/plugins/tools/filterEffectTool/KarbonFilterEffectsTool.cpp 1d02cca 
>   karbon/ui/KarbonView.cpp 090490ea 
>   kpresenter/part/tools/animationtool/KPrAnimationTool.h 117bc61 
>   kpresenter/part/tools/animationtool/KPrAnimationTool.cpp 0a1b997 
>   kpresenter/part/tools/animationtool/KPrClickActionDocker.h 13039f0 
>   kpresenter/part/tools/animationtool/KPrClickActionDocker.cpp fc6f238 
>   krita/plugins/tools/defaulttools/kis_tool_path.h f57a1fa 
>   krita/plugins/tools/defaulttools/kis_tool_path.cc 80a31cf 
>   krita/plugins/tools/selectiontools/kis_tool_select_path.h 7bb8a14 
>   krita/plugins/tools/selectiontools/kis_tool_select_path.cc cd4c40d 
>   krita/ui/kis_view2.cpp 31d6d8f 
>   libs/flake/KoCanvasControllerWidget.h 384c928 
>   libs/flake/KoCanvasControllerWidget.cpp 47c4afb 
>   libs/flake/KoToolBase.h 860a77c 
>   libs/flake/KoToolBase.cpp 456587d 
>   libs/flake/KoToolBase_p.h 49bc2f9 
>   libs/flake/KoToolManager.cpp 3b6554a 
>   libs/flake/tools/KoCreatePathTool.h 325af3b 
>   libs/flake/tools/KoCreatePathTool.cpp ca8f373 
>   libs/flake/tools/KoPathTool.h bcd6d95 
>   libs/flake/tools/KoPathTool.cpp 7f94ce1 
>   libs/kopageapp/KoPAView.cpp c53edec 
>   libs/kopageapp/tools/backgroundTool/KoPABackgroundTool.h 17a83b2 
>   libs/kopageapp/tools/backgroundTool/KoPABackgroundTool.cpp 0b16048 
>   libs/main/KoDockerManager.h 3ec84b9 
>   libs/main/KoDockerManager.cpp 93f1b3e 
>   libs/main/KoMainWindow.cpp e8edcb8 
>   libs/main/KoToolDocker.cpp c9aacce 
>   libs/main/KoToolDocker_p.h 3f965dd 
>   plugins/artistictextshape/ArtisticTextTool.h 0c5bc6b 
>   plugins/artistictextshape/ArtisticTextTool.cpp beb53f4 
>   plugins/defaultTools/connectionTool/ConnectionTool.h 09ece57 
>   plugins/defaultTools/connectionTool/ConnectionTool.cpp e0d4594 
>   plugins/defaultTools/defaulttool/DefaultTool.h 724798f 
>   plugins/defaultTools/defaulttool/DefaultTool.cpp c9fb9ab 
>   plugins/defaultTools/guidestool/GuidesTool.h d8e2bf7 
>   plugins/defaultTools/guidestool/GuidesTool.cpp 2983562 
>   plugins/textshape/ReferencesTool.h cee93be 
>   plugins/textshape/ReferencesTool.cpp 11b2fa8 
>   plugins/textshape/ReviewTool.h c25d9aa 
>   plugins/textshape/ReviewTool.cpp d35cf18 
>   plugins/textshape/TextTool.h 8753e06 
>   plugins/textshape/TextTool.cpp 0a76eaf 
>   plugins/treeshape/TreeTool.h 0c8733c 
>   plugins/treeshape/TreeTool.cpp 5c26dc9 
>   tables/CMakeLists.txt b37f21c 
>   tables/part/View.cpp 82bbcbf 
>   tables/shape/TableTool.h 45a9ab1 
>   tables/shape/TableTool.cpp 1d54e92 
>   tables/ui/CellToolBase.h 1e85233 
>   tables/ui/CellToolBase.cpp 3557fb1 
>   tables/ui/SimpleBorderWidget.h PRE-CREATION 
>   tables/ui/SimpleBorderWidget.cpp PRE-CREATION 
>   tables/ui/SimpleFillWidget.h PRE-CREATION 
>   tables/ui/SimpleFillWidget.cpp PRE-CREATION 
>   tables/ui/SimpleMergeWidget.h PRE-CREATION 
>   tables/ui/SimpleMergeWidget.cpp PRE-CREATION 
>   tables/ui/SimpleNumFormatWidget.h PRE-CREATION 
>   tables/ui/SimpleNumFormatWidget.cpp PRE-CREATION 
>   words/part/KWGui.cpp 7ec4d16 
> 
> Diff: http://git.reviewboard.kde.org/r/101384/diff
> 
> 
> Testing
> -------
> 
> checking if user interface still works and making sure no crashes occur
> 
> 
> Thanks,
> 
> Samuel
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/calligra-devel/attachments/20110520/22058970/attachment.htm>


More information about the calligra-devel mailing list