Amarok 2.2.2 system configuration / and does not find collection backend ("SOLVED")

Martin Steigerwald Martin at
Fri Jan 15 11:36:39 UTC 2010

Am Freitag 15 Januar 2010 schrieb Jeff Mitchell:
> On 01/15/2010 05:56 AM, Martin Steigerwald wrote:
> > A kbuildsycoca4 --noincremental *after* installing Amarok 2.2.2 then
> > did the trick. The one I ran before upgrading Amarok did not.
> Well, right. Because the plugin versions changed. Running a
>  kbuildsycoca with the old plugin versions installed isn't going to
>  update the cache with the new plugin version information...
> > IMHO manually this shouldn't be necessary.
> I'm not sure when it's supposed to kick off manually or not. I do
> believe it's run on login, so a logout/in should probably have fixed
>  it.
> I know on Gentoo at least they tried for a while to run kbuildsycoca4
> after ebuild installation, but I guess it requires a running X server
> for some reason so they aborted that. (Maybe *that* would be something
> good to ask about in an upstream bug report.)

Hmmm, I am not so sure it does. At least it runs via SSH from my T42 to my 
T23 without DISPLAY=:0.

So it would be a good idea if the package post-install runs kbuildsycoca4 
--noincremental? But how to reliably detect for which users? Well if its 
run after a login it would need to run it for each logged in KDE user.

I still think Amarok/KDE itself should handle such upgrades gracefully. It 
shoul automatically handle updates to the configuration. And I think it 
tried, cause I got this system configuration update dialog. (I meant KDE 
with upstream - from a Debian point of view.)

Well I think let's see whether that happens to any other users.

Martin 'Helios' Steigerwald -
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the Amarok mailing list