1.4.3 [___stripped][frames: 0][xine]

Antoine Latter alatter at cae.wisc.edu
Thu Sep 7 01:44:53 UTC 2006

I just upgraded to 1.4.3 today, from the kubuntu.org repositories.  The gory 
details of my system are on the backtrace enclosed bellow.

The problem is that Amarok crashes on (or shortly after) startup.  The app 
manages to draw the playlist and other things, but crashes before any user 
interaction is possible.

Enclosed is my theory on what's happening, as well as a backtrace and some 
other information.  I hope this is the right list to send this sort of thing 

The problem I'm having is two-fold:  something is screwed up with mDNS or some 
other zeroconf thing on my installation.  This causes DNS resolution to fail, 
which (presumably) causes amarok to panic and crash.

Let's first discuss the state of my avahi install:  it's slightly fucked.

Bellow is the partial output of "avahi-browse -a"

+ ath0 IPv4 askol [00:0f:b5:86:e7:42]                     Workstation          
+ ath0 IPv4 gort [00:0a:95:b4:46:84]                      Workstation          

"askol" is the local computer.  "gort" is an iBook elsewhere on the network.

The command "ping askol.local" does what it expects:  it pings my machine.
However, when I try "ping gort.local" ping fails because it can't resolve the 
domain name.  I have no idea why this happens.

But it does!  And Amarok does not respond to this gracefully.  Enclosed is 
another partial output of "avahi-browse -a":

+ ath0 IPv4 Christopher Clark’s Music                   iTunes Audio Access  
+ ath0 IPv4 Antoine                                       iTunes Audio Access  

As you can see, there are two DAAP resources on the local network.  And below 
is the last thing I see at the terminal when executing amarok:

amarok: BEGIN: void DaapClient::foundDaap(KSharedPtr<DNSSD::RemoteService>)
amarok: END__: void DaapClient::foundDaap(KSharedPtr<DNSSD::RemoteService>) - 
Took 0.0029s
amarok: BEGIN: void DaapClient::foundDaap(KSharedPtr<DNSSD::RemoteService>)
amarok: END__: void DaapClient::foundDaap(KSharedPtr<DNSSD::RemoteService>) - 
Took 0.0024s
amarok: BEGIN: void DaapClient::resolvedDaap(bool)
amarok:       Christopher Clark’s Music 
christopher-clarks-powerbook-g4-15.local local _daap._tcp
/tmp/buildd/kdelibs-3.5.4/./kdecore/network/kresolverworkerbase.cpp:136: void 
KNetwork::KResolverWorkerBase::acquireResolver(): Assertion `th != 0L' 

The last thing it tried to do was resolve the zeroconf name associated with 
the iBook's music share.  As I've demonstrated with ping above, non-local 
zeroconf resources can't resolve.

On a different execution, Amarok saw the local share first, tried to do the 
DNS resolution, saw the non-local share, tried to do the resoltion and then 
crashed.  I can't reproduce this because the order in which Amarok discovers 
the zeroconf services is not fixed.

This isn't a perfect theory, because sometimes the last thing I see when 
executing Amarok is an attempt to do DNS resolution on a local service, and 
then the crash.  The next thing I plan to try is to disable all of the 
running avahi-related daemons and then reboot.

So while I know that you (probably) can't fix my zeroconf problems, it'd be 
nice if Amarok didn't die because of them :-)



Amarok has crashed! We are terribly sorry about this :(

But, all is not lost! You could potentially help us fix the crash. Information 
describing the crash is below, so just click send, or if you have time, write 
a brief description of how the crash happened first.

Many thanks.

The information below is to help the developers identify the problem, please 
do not modify it.

======== DEBUG INFORMATION  =======
Version:    1.4.3
Engine:     xine-engine
Build date: Sep  6 2006
CC version: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
KDElibs:    3.5.2
Qt:         3.3.6
TagLib:     1.4.0
CPU count:  1

==== file /usr/lib/amarok/amarokapp =======
/usr/lib/amarok/amarokapp: symbolic link to `/usr/bin/amarokapp'

==== (gdb) bt =====================
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
==== (gdb) thread apply all bt ====

==== kdBacktrace() ================
0: /usr/lib/libkdecore.so.4(_Z11kdBacktracei+0x45) [0xb71f1f67]
1: /usr/lib/libkdecore.so.4(_Z11kdBacktracev+0x26) [0xb71f22ac]
2: amarok(_ZN6amaroK5Crash12crashHandlerEi+0xcd1) [0x804cab1]
3: [0xffffe420]
4: /lib/tls/i686/cmov/libc.so.6(abort+0xe9) [0xb67f92b9]
5: /lib/tls/i686/cmov/libc.so.6(__assert_fail+0x101) [0xb67f0f51]
6: /usr/lib/libkdecore.so.4
7: /usr/lib/libkdecore.so.4
8: /usr/lib/libkdecore.so.4
(_ZN8KNetwork8Internal18KGetAddrinfoWorker3runEv+0xc9) [0xb7304e0f]
9: /usr/lib/libkdecore.so.4(_ZN8KNetwork8Internal15KResolverThread3runEv+0x35) 
10: /usr/lib/libqt-mt.so.3(_ZN15QThreadInstance5startEPv+0x86) [0xb6278f9a]
11: /lib/tls/i686/cmov/libpthread.so.0 [0xb6c28341]
12: /lib/tls/i686/cmov/libc.so.6(__clone+0x5e) [0xb68984ee]

More information about the Amarok mailing list