How to get ZeroConf working?

Mats Ahlgren mats_a at MIT.EDU
Fri Sep 1 06:28:18 UTC 2006


Might anyone know how to get ZeroConf working to try out AmaroK's new DAAP feature? Any help would be much appreciated.


I'm using distro=Kubuntu version=Dapper.

I've followed the instructions on to install Avahi with proper KDE bindings, but to no avail. Both Konqueror url=zeroconf:/ and AmaroK fail to show the zeroconf/DAAP services on the network (Konqueror claims to see 0 servers). It seems to be a problem with the KDE-Avahi bindings, because Avahi works fine (as evidenced by running avahi-discover).
I failed to build kdnssd-avahi from source so instead I used Alien on the appropriate RPM package I found, then installed it forcefully overwriting the /usr/lib/ provided by kdelibs. This started a host of other problems:
1) in Konqueror when I access the URI zeroconf:/ :
	"Could not start process Unable to create io-slave:\nklauncher said: Error loading 'kio_zeroconf'."
2) when launching Amarok :
	"KLibLoader could not load the plugin:\nlibamarok_daap-mediadevice\n\nError message:\n/lib/tls/i686/cmov/ version `GLIBC_2.4' not found (requires by /usr/lib/"

I also tried installing the zeroconf package with Aptitude/apt-get, but that didn't work either for some reason.
I also tried installing Apple's very own mdns daemon, which didn't work for some reason.
Why didn't it work? All I could tell is that when I used Konqueror url="zeroconf:/" in each case, it resulted in finding 0 servers or said it could launch the proper io-slave as above.

(I found a comment on Ian Monroe's blog about a similar problem with DAAP servers not appearing, and necessitating the use of ksyncoca, but that shouldn't be the problem because I rebooted after every config I tried?)


More information about the Amarok mailing list