Depend on Qt4.6 - Yay or Nay?

Myriam Schweingruber schweingruber at
Sat Jun 5 18:21:38 CEST 2010

On Sat, Jun 5, 2010 at 17:54, Casey Link <unnamedrambler at> wrote:
> Hey devs,
> It's been 4 days of virtual silence regarding this issue...
> Before reverting Ralf's commit that is currently failing our
> continuous integration server, or installing the little hack Thomas
> suggested, lets come to a consensus for Qt 4.6.
> From the extreme lack of "I can't build!" complaints (I've seen one,
> and he wasn't a developer), we all obviously have Qt 4.6 installed and
> so do most of our git users. (or of course no one but me has built
> Amarok in 4 days).

We can switch as soon as KDE 4.5 is release. This is our usual way of
changing Qt versions. As long a not all distros ship KDE SC 4.4.x,
there is no possibility to switch. Keep in mind that Debian stable
doesn't without activating additional repositories...

We really shouldn't take the git users using a higher Qt version as a
measure, these are only a tiny fraction of all users we have.

Regards, Myriam.
Protect your freedom and join the Fellowship of FSFE:
Please don't send me proprietary file formats,
use ISO standard ODF instead (ISO/IEC 26300)

More information about the Amarok-devel mailing list