extragear/multimedia/amarok/src/podcasts
Bart Cerneels
bart.cerneels at kde.org
Wed Mar 12 08:31:03 CET 2008
On Wed, Mar 12, 2008 at 7:24 AM, Maximilian Kossick
<maximilian.kossick at googlemail.com> wrote:
> Please please don't put method implementations into important header
> files if it can be avoided, even if they are as simple as that.
> Changing them means recompiling all files which include the header
> file, which is a unnecessary waste of time. Not all of us have an
> icecream cluster available.
These are just stub functions to make PodcastCollection a
MemoryCollection before I started the (for me) hard task of SQL'izing
it. Those functions will get reimplemented in SQL in a proper cpp
file.
But thanks for reminding me of good coding practices, I know I need them :)
>
>
>
> On Tue, Mar 11, 2008 at 11:14 PM, Bart Cerneels <bart.cerneels at kde.org> wrote:
> > SVN commit 784629 by shanachie:
> >
> > Better name for functions.
> >
> >
> > M +2 -2 PodcastMeta.h
> >
> >
> > --- trunk/extragear/multimedia/amarok/src/podcasts/PodcastMeta.h #784628:784629
> > @@ -158,8 +158,8 @@
> > virtual void setDuration( int duration ) { m_duration = duration; };
> > virtual void setGuid( const QString &guid ) { m_guid = guid; };
> >
> > - virtual int sequence() { return m_sequenceNmbr; };
> > - virtual void setSequenceNumbr( int sequenceNumber ) { m_sequenceNmbr = sequenceNumber; };
> > + virtual int sequenceNumber() { return m_sequenceNmbr; };
> > + virtual void setSequenceNumber( int sequenceNumber ) { m_sequenceNmbr = sequenceNumber; };
> >
> > virtual PodcastChannelPtr channel() { return m_channel; };
> > virtual void setChannel( const PodcastChannelPtr channel ) { m_channel = channel; };
> >
>
>
> _______________________________________________
> Amarok-devel mailing list
> Amarok-devel at kde.org
> https://mail.kde.org/mailman/listinfo/amarok-devel
>
More information about the Amarok-devel
mailing list