Review Request: Drop Xinerama related options in KWin

Thomas Lübking thomas.luebking at web.de
Sun Jan 22 19:54:50 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/103756/#review10006
-----------------------------------------------------------



kwin/geometry.cpp
<http://git.reviewboard.kde.org/r/103756/#comment8235>

    should possibly be
    
    if (is_multihead)
       screen = screen_number;
    else if (screen == -1)
     ....??
    
    is screen_number part of the "make kwin work on real multihead" thing? looks like it's statically assigned to DefaultScreen(dpy) in main.cpp what does not cover the case when one head has multiple (randr) screens?!



kwin/geometry.cpp
<http://git.reviewboard.kde.org/r/103756/#comment8234>

    not your change, but looks like senseless code duplication.
    esp: why does the is_multihead block test "screen < screenarea[desktop].size()" but uses screenarea[desktop][screen_number]?
    
    Otherwise the blocks are equal but for screen/screen_number



kwin/geometry.cpp
<http://git.reviewboard.kde.org/r/103756/#comment8233>

    is now unconditionally "sarea"



kwin/geometry.cpp
<http://git.reviewboard.kde.org/r/103756/#comment8237>

    since we acquire sarea/warea above (including some sanity check), can't we just return it here?
    
    Otherwise it maybe shouldn't be calculated / fetched against screenarea[desktop] unconditionally but just for MaximizeArea & resp. WorkArea



kwin/manage.cpp
<http://git.reviewboard.kde.org/r/103756/#comment8236>

    afaics this option is dead.
    I've that key nowhere in no config and it wasn't provided by the xinerama kcm either


- Thomas Lübking


On Jan. 22, 2012, 10:21 a.m., Martin Gräßlin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/103756/
> -----------------------------------------------------------
> 
> (Updated Jan. 22, 2012, 10:21 a.m.)
> 
> 
> Review request for kwin and Plasma.
> 
> 
> Description
> -------
> 
> As discussed on the mailinglist: drop of the xinerama related options and the kcm. Given that the show unmanaged windows on option is in fact not used, I dropped the complete KCM.
> 
> 
> Diffs
> -----
> 
>   kcontrol/CMakeLists.txt 8cd9a46 
>   kcontrol/xinerama/CMakeLists.txt fe332e5 
>   kcontrol/xinerama/Messages.sh f4aa134 
>   kcontrol/xinerama/interface_util.h 8a4fcd1 
>   kcontrol/xinerama/kcmxinerama.h 18b9241 
>   kcontrol/xinerama/kcmxinerama.cpp a456b2c 
>   kcontrol/xinerama/test_kcm_xinerama.cpp a358a2c 
>   kcontrol/xinerama/xinerama.desktop e8ce525 
>   kcontrol/xinerama/xineramawidget.h 2c446a2 
>   kcontrol/xinerama/xineramawidget.cpp df9cb2f 
>   kcontrol/xinerama/xineramawidget.ui 90ec4d4 
>   kwin/geometry.cpp a414e26 
>   kwin/manage.cpp c551eac 
>   kwin/options.h 9dc29cf 
>   kwin/options.cpp d496569 
>   kwin/tabbox/tabbox.cpp 3051316 
>   kwin/toplevel.cpp ffe7f0c 
>   kwin/workspace.cpp 69b4ecb 
> 
> Diff: http://git.reviewboard.kde.org/r/103756/diff/diff
> 
> 
> Testing
> -------
> 
> Fullscreen: works
> Maximize: works
> Movment: works
> Placement: works
> 
> 
> Thanks,
> 
> Martin Gräßlin
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20120122/d794aae2/attachment-0001.html>


More information about the Plasma-devel mailing list