Review Request: Replace the "i" icon for showing/hiding the notifications and jobs with a spinner.

Rob Scheepmaker r.scheepmaker at student.utwente.nl
Wed Apr 15 19:14:45 CEST 2009


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/594/
-----------------------------------------------------------

Review request for Plasma.


Summary
-------

As discussed on the "Systray jobs and notifications" threat on plasma-devel, this patch replaces the "i" icon with a spinner. If there are jobs running, the spinner will actually spin, else it will just be a static image. I think maybe it would be nice to support themes prividing a seperate static svg for the static image case later. Also 1 or 2 numbers in front of the spinner will indicate how much items there are, and how many of them are completed. (see the mailing list discussion for details)
This patch adds some features to the BusyWidget, that were needed for this use case. I'm not sure if they all deserve a place in the public api though. These features are:
* clicked() signal
* setLabel and label(), to set a label that is painted in front of the spinner
* setRunning and running(). Another name might be more appropriate though, setAnimated/isAnimated() maybe?

The first 2 can easily be moved to a private subclass of busy widget in systemtray if needed. I think there might be more usecases for them to justify a place in public API though. I'd like to hear your opinion about this.


Diffs
-----

  /trunk/KDE/kdebase/workspace/plasma/applets/systemtray/ui/applet.h 951732 
  /trunk/KDE/kdebase/workspace/plasma/applets/systemtray/ui/applet.cpp 951732 
  /trunk/KDE/kdebase/workspace/plasma/applets/systemtray/ui/extendertask.h 951732 
  /trunk/KDE/kdebase/workspace/plasma/applets/systemtray/ui/extendertask.cpp 951732 
  /trunk/KDE/kdebase/workspace/plasma/dataengines/applicationjobs/kuiserverengine.cpp 951732 
  /trunk/KDE/kdelibs/plasma/extenderitem.cpp 951724 
  /trunk/KDE/kdelibs/plasma/widgets/busywidget.h 951724 
  /trunk/KDE/kdelibs/plasma/widgets/busywidget.cpp 951724 

Diff: http://reviewboard.kde.org/r/594/diff


Testing
-------


Thanks,

Rob



More information about the Plasma-devel mailing list