Pino,<div><br></div><div>Thank you for the time you took to review the code. I think I may have sent an outdated patch as Albert addressed a few of these issues with me as well. However, every other point you bring up is valid. </div>
<div>
<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
> + m_model = new QFileSystemModel( this );<br>
<br>
please use a KDirModel<br></blockquote><div><br></div><div>I just want to know why? Maybe KDirModel may be a better KDE api option but its not necessarily easy to set up. This would require me to reimplement quite a few things in the dialog( which is not a problem I just want to know that its justified). If a KDirModel is necessary then I will definitely need more time.</div>
<div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
> + // Hide file size and type<br>
> + m_dlg->MetaFileList->hideColumn( 1 );<br>
> + m_dlg->MetaFileList->hideColumn( 2 );<br>
<br>
you have a proxy model, so make that proxy do the column hiding job (not<br>
sure it is needed that way with KDirModel)<br></blockquote><div> </div><div>Because the proxy model would have to implement catching these which would have taken a few more lines of code. That's not a big deal but I will wait until the KDirModel.</div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
> + m_dlg->MetaFileList->setColumnWidth( 0, 350);<br>
<br>
why this hardcoded value?<br></blockquote><div>This has been bugging me for a while. I cant get the view to resize the table to contents efficiently. The resizeColumnsToContents() is a slot I havent quite figured out yet. Any suggestions?</div>
<div><br></div><div><span style="border-collapse:collapse;font-family:arial, sans-serif;font-size:13px">>> + i18n( "Warning " ),<br>
<br>> + trailing space in i18n() string text, and a bit too generic</span></div><div><span style="border-collapse:collapse;font-family:arial, sans-serif;font-size:13px"><br></span></div>
<div><font face="arial, sans-serif"><span style="border-collapse:collapse">Hmmm, any suggestions?</span></font></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
> + modifiedData =<br>
> modifiedData.toString().remove(QRegExp(".xml$"));<br>
> + modifiedData =<br>
> modifiedData.toString().remove(QRegExp("^[0-9]+\."));<br>
<br>
pretty inefficient; you're getting the string out of the variant, do a<br>
removal of some text using two regexps (which are not needed), and then<br>
converting to qvariant again; just get the string out once, do the<br>
replacements and reassign back to the variant<br></blockquote><div><br></div><div>I have refactored this process a bit. While I agree that a regular expression may be heavy duty it does guarantees a match and delete of a file size of varying digit lengths as well as a .xml that __has__ to be at the end.</div>
<div><br></div><div><font face="arial, sans-serif"><span style="border-collapse:collapse"><br></span></font></div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">- i'm not sure having both configuration and "handling" in the very same<br>
ui is ideal... maybe one could rename the "personal identity"<br>
configuration page to "personal data", and put just the metadata<br>
checkbox there, while leaving the actual handling reachable from<br>
somewhere else (settings -> handle (personal) meta data?)<br></blockquote><div> </div><div>I understand what you mean and this is why I have held off a little on fixing some of the issues that will take a longer time. Does anybody else have any thoughts on this?</div>
</div></div>